Add construction set - crashes Rhino

Hi, Using the Rhino plugin i tried to Add a construction set. Rhino crashes right after that.
As a matter of fact Rhino crashes also when trying to edit an existing material/construction.

Hi Abraham! I tried to do some editing to crash Rhino on my side but it was unsuccessful. Can you share a screenshot of how you are trying to do it and when does it crash. Thanks!

PS: Thank you so much for finding and reporting all the bugs! We knew this will happen. :grinning:

Thanks @mostapha for testing as well. I just did a same test, and could not recreate this issue.
Hi @ayezioro could you provide us some instructions on how to recreate your problem?

Hi @mingbo and @mostapha,
I just push the Add button. After a few seconds Rhino crashes. Don’t get any other window.
Right now tried again and there are different situations and probably more to check:

  1. Add materials seems to work.
  2. Add construction Opaque, i get this error:
  3. Add construction Window: Crashes Rhino!!
  4. Add construction set. If i push the button once i get the following:

    But if i push Add again or Edit, Rhino crashes.

So far didn’t check other options.


1 Like

Hi @ayezioro, I think there is an issue with your ladybug_tools folder.

resources folder is suppose to be

> C:\Users\ayezi\ladybug_tools\resources\

I am not sure why you have openstudio-3.2.0 in your ladybug_tools folder, and have resources folder saved under it. For OpenStudio, it should be installed to C:\Users\ayezi\ladybug_tools\openstudio (without version)

If you are using our installer, it already includes the OpenStudio, you don’t have to install it manually.

Hi @ayezioro . Even I am also getting the same error. It crashes with the commands mentioned above.

Hi @asisnath, do you also have OpenStudio-3.2.0 folder in ladybug_tools folder?

Hi @mingbo. After installation I have all these files in Ladybug_tools folder.

OS.3.2 appeared after installation

Hi @asisnath, did you installed openstudio-3.2.0 previously by yourself? Could you do me a favor: try to remove this openstudio-3.2.0 folder and start the Rhino again? (all OpenStudio files should be included in openstudio folder, so you can safely remove the openstudio-3.2.0)

@mingbo. OS 3.2 was not installed by me earlier. I guess it was installed during pollination process. I uninstalled it and its working fine now. Will keep on testing and let you know if any error pops up.

1 Like

Hi @mingbo,
The reason i have OS3.2 there is that i still use the HBLegacy and i need the OS version (older) installed under C:.
The resources folder was not defined by me, or OS, i suspect this is related to Pollination procedure itself. If you see in this image the date of the folder you’ll see that it is from yesterday night, after i installed the RhinoPollination, and BTW, the folder is empty or to be more accurate, the resources/standards there is empty:

At first this is what i had. But with the LBT updates i needed a more updated OS version.
So i’m right now in a situation that, i prefer not to uninstall anything …
Any suggestions?

Hi @ayezioro, there are a several things that we need to clarify:

  1. So the legacy version doesn’t use the openstudio folder installed inside of ladybug_tools folder. It only finds the C:\OpenStudio-XX under your C drive.

  2. Removing the openstudio-3.2.0 from ladybug_tools folder will not affect the LBT plugin, because LBT plugin uses C:\Users\ayezi\ladybug_tools\openstudio instead of C:\Users\ayezi\ladybug_tools\openstudio-3.2.0

  3. Our installer comes with the newest compatible OpenStudio version with the stable LBT plugin. In this case, it is 3.2.0 already. In the future, if you want to use the development version of LBT plugin that uses a newer OpenStduio, you can install it to C:\Users\ayezi\ladybug_tools\openstudio instead of C:\Users\ayezi\ladybug_tools\openstudio-3.2.0, which will override the OpenStudio that comes with out installer.

Hope this clears your doubts.

1 Like

Want to report that after uninstalling OS3.2 from the ladybugtools folder now all model resources work fine.
After that i made a clean install of OS (without version number) and Pollination plugin and it works fine too.
Seems to be that the issue is solved. Right?

Thanks for keeping us updated. Yes, I think so. The issue was the openstudio-3.2.0 folder inside the ladybug_tools folder.

Note: you don’t have to reinstall the OS, our installer includes the OpensStudio 3.2.0 already.


This was clear.

Here what i did at the time i installed OS3.2 is to trash the OS folder (yes!! Trash it). I was thinking that it might “confuse” LBT.

OK. The installer i have, expired a while ago. But now i understand better.
Thanks @mingbo,

Just for clarification by installer here @mingbo is referring to the Pollination Rhino plugin installer and not the LBT Grasshopper plugin installer. It also includes the latest version of LBT plugins for Grasshopper which comes with OpenStudio 3.2.0.

Ajjjaaaaa!! Okeyyy!
Thanks @mostapha,

1 Like