Apertures plenty of apertures

Hi all
does anybody know why I get every aperture twice ( although it is a single face?

They are passed trough to Grasshopper also

Edit: Made another attempt. => remove aperture properties => recreate them => Now I have 3 of them…H100 028

2nd edit: further trying now I get 4 at a time… :smirk:

Thanks @martin6,

There is a bug when removing an aperture by “PO_RemoveProperties” and adding it back again.
I just fixed it, will be ready in the next version.

Hi @martin6 this issue should be fixed in the latest version now. Please have a look and let me know if it works as expected.

Sorry @mingbo I can’t confirm. Updated to
Worked on with H028 Model and here is the result.
Some rooms have a single or several single windows, others one window 3x or several 3 times.
In the picture a room with both versions.

1 Like

Hi @martin6 could you please provide more information on how this duplicated apertures happen at the first place. Such as what commands you used that duplicate aperture. It’d be great if you could make a video to demonstrate it.

Hi @mingbo here you are!

No work or copying done before. Just opened the file.

1 Like

Hi @martin6, thanks, this is very helpful.

I just did the same test on my side, but it seems I couldn’t recreate this. Could you please try a new box room to see it has the same effects? If not, it means there is some wrong with the model that you are working on, in that case, I will need your model for debugging.

Meanwhile, I am adding some checks for preventing that an aperture is added multiple times. Hopefully this might help a little bit.

Hi @mingbo

take the 100 028_base Model

Just tried with a simple model => it works.
Regarding the model 028 I can’t remember every step I made building this model but from the layer structure it looks like I assigned the room properties using the PO_MatchRoomProperties command.

Thanks @martin6,

It seems all works fine with the latest version of the plugin, here is my test with your model, please let me know if you still have the same issue with the new version:

1 Like

Hi @mingbo it looks all right on my side to :smiley: