Applying_User defined data error on rooms

Hi. I am facing a strange issue while applying user defined data to rooms both in Revit and rhino plugins . For example ;

  1. When i apply default construction set to the room and click ok, it assigns the construction set as required. When i reopen the edit tab I could see the default construction set is applied successfully.

  2. But when i assign a user defined construction set and click ok and again reopen edit tab the construction set is again back to default property.

Though pollination is reading my user defined file names but not been able to assign it. For information I have already created user defined json file and saved in resource folder.

I have all updated standard LBT tools and even created all the user defined file with LBT 1.3.0 version

Hi @asisnath, what version of the Rhino plugin are you using? You should be able to find the version by using the PO_PluginInfo command.

This is the message with PO_Plugininfo command. -

This issue I am also facing with Revit plugin

1 Like

One update to this issue. Along with not being able to apply user defined data to model, when I try to bring pollination model to grasshopper using grasshopper plugin I get following error. This shows though Rhino UI doesn’t show custom data is applied it tried to apply user defined data but internally it tried to do so. It can read the custom file names but not the data inside.

Hello @asisnath and @mostapha

I observed a familiar behavior when I tried to assign an Airwall to a room. It was kept only when I saved the file right after the action.
I’m still with

Hi @mostapha. I have an update to this topic. I Reinstalled rhino plugin 1st (after uninstalling the installed version as discussed with @chriswmackey ) and then Updated the LBT through versioner and now everything works fine again with Rhino plugin. I could assign now the properties in Rhino UI.

I did the same process of reinstalling Revit plugin but unfortunately the error in revit plugin still persists. For your information I have installed Revit plugin version 2.32.5. Any suggestion on Revit plugin!

1 Like

I just wanted to clarify @asisnath 's comment - this issue resulted from people uninstalling the LBT Grasshopper plugin (with the on Food4Rhino), which also effectively uninstalls parts of the Rhino plugin.

So, for anyone who already has the Rhino plugin installed, JUST USE THE LB VERSIONER TO UPGRADE TO LBT 1.3. You don’t have to worry about using the if you already have the latest Rhino plugin installed.


Hi @asisnath and @martin6,

There is a new developer version of the Rhino plugin, which includes some fixes in the Object Property UI, and loading user’s data.
Please take a look at the new installer, and feel free to let us know if you have any questions.


Hi @mingbo. Thank you for the update. Issue with Rhino plugin is solved. But I am still facing the same issue with revit plugin. Any update on revit plugin?

In my case it seems to work fine now. Thank you.

Hi @martin6 . Is the revit plugin working fine for you?

Hi @asisnath . I don’t use Autodesk Revit.

Hi @asisnath, no our Revit plugin hasn’t been updated. @ksobon is on vacation this week.


I marked this discussion as solved. We can continue the conversation for the Revit plugin under the other topic in #revit-plugin category. Thank you @mingbo for fixing the issue.

1 Like