Cannot run adaptive comfort map recipe


I have been trying to run the adaptive comfort map recipe from a revit-exported model and I get a >>‘module’ object has no attribute ‘model_to_json_grid_room_check’<< error

The model has curtain walls and I added some grids in order to run the mapping.

I have tested an annual energy use on the same model and it seems to work. I also tried to disassemble the model in rooms and reassemble it with a new grid using ladybug-tools and I get the same error.

One of the problem that I get when I do a validation check of the HBJSON is a non coplanarity of some faces, which is a bit strange coming from a Revit model :

Input model version: 1.45.0
The input file has a higher version (1.45.0) than the tagert version (1.45.0).

Face “Room_b2db7efe-906b-4dba-b4be-01ad238ddbdd-00063950_Face_3” is not planar.
Vertex Point3D (376.61, -29.94, 15.48) is out of plane with its parent face.
Distance to plane is 0.12173578914
Aperture “Room_b2db7efe-906b-4dba-b4be-01ad238ddbdd-00063944_Face_3_Aperture_7” is not coplanar or fully bounded by its parent Face “Room_b2db7efe-906b-4dba-b4be-01ad238ddbdd-00063944_Face_3”.
Aperture “Room_b2db7efe-906b-4dba-b4be-01ad238ddbdd-00063947_Face_5_Aperture_0” is not coplanar or fully bounded by its parent Face “Room_b2db7efe-906b-4dba-b4be-01ad238ddbdd-00063947_Face_5”.
Aperture “Room_b2db7efe-906b-4dba-b4be-01ad238ddbdd-00063947_Face_5_Aperture_1” is not coplanar or fully bounded by its parent Face “Room_b2db7efe-906b-4dba-b4be-01ad238ddbdd-00063947_Face_5”.
Aperture “Room_b2db7efe-906b-4dba-b4be-01ad238ddbdd-00063947_Face_6_Aperture_9” is not coplanar or fully bounded by its parent Face “Room_b2db7efe-906b-4dba-b4be-01ad238ddbdd-00063947_Face_6”.
Aperture “Room_b2db7efe-906b-4dba-b4be-01ad238ddbdd-00063b06_Face_8_Aperture_5” is not coplanar or fully bounded by its parent Face “Room_b2db7efe-906b-4dba-b4be-01ad238ddbdd-00063b06_Face_8”.

Thanks in advance for any tip.


Hi @julien ,

since I’m not using Revit or the Revit Rhino Plugin I’m not able to answer all your questions but some things I think I can help you with.

If you read around the forum a bit, you’ll find a lot of posts where the developers complain about poor quality files out of the architectural world.
Therefore the checks in the Rhino Plugin are really good and the results need to be addressed.

That isn’t much if you just have to print out a 2D drawing at the end of your modelling, but in the world of simulation it’s a no go and also the reason why your apertures don’t match the face.

I’ve attached you a stripe visualization used for quality checks in 3D modelling, showing the the misalignment of 0.12 of a single face in a wall. It might applies in your case?

@mostapha , @mingbo This could be something to implement as a check for the integrity of outside walls or visual aid to find misaligned faces in general?

Hi @julien,

Thank you for posting your question and welcome to the forum!

Is this happening on the Grasshopper side? This is because you have an older version of the Ladybug Tools installed. You should try to update the LBT installation using the update_ladybug component.

For the error messages it will be really helpful to access the Revit model on our side. We had cases that strange duplicate vertices results in non coplanar errors. Updating the LBT plugins might fix this issue right away. If it doesn’t then we will need the model to be able to debug this issue.

Am I right that this is the model that you are working with?

I can successfully import the model to Rhino but the Revit file is the best place to start debugging. For the specific error for the run the error is because EnergyPlus found a face where the area of the opening is larger than the area of the parent face. This usually happens when there are duplicate apertures in the model.

This is most likely because we have two rooms with the same ID exported from Revit. I’m not sure how this is happening. This should be caught by the validation script. @chriswmackey, do you know what’s going on here?

Sorry for the long reply, @julien! I just wrote down all my thoughts here to make sure I’m not missing anything obvious. I think the next helpful step is to check the Revit model! :grinning:

Thanks, @mostapha . You diagnosed this issue correctly that there are old core libraries here. I think these old libraries are also the cause of all the other errors we are getting here. Just run the LB Versioner component in Grasshopper, @julien , and restart Rhino. Then, I think the PO_Validate command should give you a report of all of these issues before you simulate.

1 Like

Hi @chriswmackey and @mostapha, thanks you very much for the outstanding support ! and please accept my deepest apologies for not coming back to you before. Engineering projects in emergency modes caught my time…

Following @chriswmackey instructions, I have tried to use the LB versioner and I get this error

  1. Runtime error (ImportException):
    Failed to import ladybug_rhino:
    Cannot import name give_popup_message

line 68, in script

which seems to relate to this error LBT 1.2.3 Versioner - ladybug - Ladybug Tools | Forum, so I tried to reinstall and still get the same error. I will look into it but I was sure to have downloaded and installed all libraries up to date when I started testing this. So let me know if I need to post this problem on LB discourse.

@mostapha You are right this is the model. I will send both of you the model directly (for privacy issues). As you have guessed this is a model made for another purpose that I tried to adapt instead of starting from scratch. There might be some empty rooms in it.

Many thanks for the help !

Hi @julien - my turn to apologize for being late. I think the easiest solution to solve this issue is to use the Rhino installer. It comes with the latest version of the LBT plugins for Grasshopper. Make sure you install the developer version:

Hi @mostapha, thanks for the tip ! it worked like a charm !

1 Like

I marked this as resolved since the issue discussed here has been resolved. We are continuing the conversation for reviewing the models in private messages.