Check job status not retreiving results

Hi all,

First of all thanks for granting early access to pollination!

I tried running my first recipe, but unfortunately I’m unable to get the results back into Grasshopper. The web app says it’s completed, but the job status says the job is still running and refuses to get the results. Double clicking on it and selecting the job from the list yields the same problem. Any idea what I’m doing wrong, or did I encounter a bug?

Thanks in advance!


Hi @marctavenier, thank you for letting us know. We are looking into this and will let you know the results soon.

Hi @marctavenier, I am unable to recreate this issue on my side. Are you able to recreate it again?

Note: the GH plugin’s UI usually has a max 3-5 seconds delay.

Hi @Mingbo,

Yes, it still says it 5+ hours later and after restarting Rhino several times.

Hi @marctavenier, does this file work for you? I internalized the run from your simulation.

You still need to log-in using one of the other components. (5.8 KB)

Hi @Mostapha,

I tried it and unfortunately it didn’t work. They both gave the same error. Also, the panel component shows an object instead of the cloud string as it showed in your example.

I used the pollinate component to log in.

Hi @marctavenier, thanks. That’s a different problem with how Grasshopper internalize data. It didn’t serialize to a readable object and that’s why the other component is failing. Sorry. It wasn’t really helpful.

@Mingbo, what are your thoughts? Can we create a sample C# code to help debug this? I can’t recreate the issue on my side.

Hi @Mostapha @Mingbo,

Earlier today (say a few hours ago) I checked again, and it still didn’t work. Now I checked again and it works, even though I changed nothing on my side.

I decided to check again, running a new simulation (this time an energy simulation) on the same model, but again same issue.
(simulation job: CLOUD:marctavenier/demo/6c83794d-0191-4305-bc05-2e89dfcaf998 )

If I can run some debug code, let me know. I’m glad to help!

My other computer seems to have no issue with retrieving the results, so it’s most probably a client-sided issue:

The difference between the two installations regarding plugins installed are that on my main computer I also have installed the following:

  • Lunchbox
  • FabTools
  • Bombyx 2
  • Pachyderm Acoustics
  • SnappingGecko
  • Bifocals
  • Ironbug

Could any of these be the problem, or might it be something else?

Thank you @marctavenier for providing detailed explanation. I assume if it was a dll conflict the plugin would have failed to load in the first place. This is really strange that it makes the call to the server but somehow it interprets the response as not completed.

It’s something for @Mingbo to help you with probably with some more logging on your side to be able to find the source of the issue.

Hi @marctavenier,

I created a component here for you to debug.
It checks the server for getting the raw response data of your job.

You will need to login first via one of Pollination component before running this debug component. (7.6 KB)

Please copy your output data here for the job that has different job status than what you see from our web app.

Meanwhile, could you also attach your log files that you can find from here:

Hi @Mingbo,

Here is the response data I’m getting for a run that is already listed as finished on the Web app:

  "status": {
    "status": "Created",
    "type": "JobStatus",
    "api_version": "v1beta1",
    "id": "30425c7e-55fe-4f48-829f-e94c34b02b19",
    "started_at": "2021-06-09T08:22:50.568254",
    "annotations": {},
    "source": "",
    "runs_pending": 0,
    "runs_running": 0,
    "runs_completed": 0,
    "runs_failed": 0

The log file: (1.4 KB)

Let me know if I can be of any other help.

1 Like

Thanks, we are investigating this with our backend server as well. I will let you know once we identify the source of the problem.

cc @antoine

1 Like

Hi @marctavenier,

We recently have a several fixes on our backend that related to monitoring a job’s status.
Would you mind to do a new test to see if the issue remains?

Hi @Mingbo,

That seems to have done the trick, thank you!


1 Like