Dealing with Voids/Small Gaps from Revit Export

@mostapha
Problem
There are typically voids/shafts/ or other small cavities in Revit model that lead to many gaps in exported hbjson/dfjson model.
Common culprits include shafts, wet walls, or columns that are surrounded by gypwall which create many small voids.

Example - columns w/ gyp wall

Current Solution
Revit - use “add all rooms” feature to fill voids with rooms. Then have many small rooms in Rhino. Use PO_MergeRooms command, then PO_Rebuild.
Feature Request
Option 1 -
Improve merge rooms command to include ability to merge rooms based on room name or area/volume. For example all rooms under 10 sf area or all rooms that contain “void” in their name, merge into adjacent room that it shares most surfaces with.

Option 2 -
Add automatic fill void command in Rhino Pollination rather than placing dummy “void” rooms in Revit. For example, on certain floor level, look for gaps in model below user set tolerance in volume/area and automatically add room or merge to adjacent room.

1 Like

Hi @victorbrac!

This sounds like a great feature to implement! It is similar to the simplify curve command in Rhino. Using Area as the tolerance for merging the rooms feels to be the better solution to me. Let us have a longer discussion on this internally with @mingbo and get back to you.

1 Like

Great, look forward to seeing this feature!

May be useful check against Pollination display name as well since small voids could be filled with “void” room name in Revit.