Double Icons after new plugin installation

Hi all,

what is best practice to get rid of double icons?

They appear for some programs out of Ladybug but not for all of them

Honeybee plus isn’t affected

We have restructured the files in the installer. If you have a version that is older than a week, you should uninstall the older installation first before installing the new one!

Ok great @mostapha this works perfectly.

Else do you have any idea how to get rid rid of all these.

we had it already here

One I could uninstall, the rest remains.
But unlike last time I’m unable to uninstall them now.

maintenancetool.exe cannot be found

Is there any location in the registry to do it manually or some other way?

Hi @martin6, if you install the plugin with the newest installer, it will automatically clean up the old versions (including folders and registry items).

Well @mingbo that’s not the case.
There are still 37 entries.
Should I install out of an administration account or is it sufficient to do it out of a user account as administrator?

Hi @martin6,

The new installer is supposed to look into the registry: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Uninstall, and find all entries that have a key “DisplayName” with the value “Ladybug Tools”, and then remove it.

But it seems doesn’t work on your machine, would you mind taking a screenshot of the registry at this path:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Uninstall, so that I can find the where the problem is?

1 Like

Hi @martin6, I created a sample installer that checks the registry and cleans up all old versions.
It’d popup a few dialogs based on your old installed versions, and you can close the “installer” after you see the “You can close the installer!” dialog (you don’t need to finish the installation).

Please let me know if it works on your machine on cleaning the old versions. Just for us to understand what happens on your side, if you don’t mind, please record the screen for us to debug why the Pollination installer doesn’t work. (4.4 MB)

Hi @mingbo
sorry for the late reply. Since a week I’m having serious trouble with my computer OS, so I will have to restore it from scratch soon. Which solves the problem, but not in the way I like.
Anyway I tried your installer. Here is the result. Nothing changed.

1 Like

Hi @martin6,

It seems the installer is unable to find the records in your Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Uninstall\. I tried to find and install the old version (1.35.44) that you installed and here is the screenshot of my installation.

The installer is able to find it on my machine but it seems not the case on your side. I really can’t find what went wrong with your machine.

I guess the best solution left here for you is to use CCleaner to clean up the registry.

@mingbo do you install and uninstall out of a user account?
What you can’t see in the clip is the part when I give permission to use the admin account for installation.