First remarks, getting started with (WIP) and Render Mode

Hello all together,

just started to work with the new Rhino Plugin and I have to say you did a great job integrating Ladybug into the Rhino scene.
Still a lot to understand for me, I’m curious how a full project turns out using the plugin and the Pollination environment.

Concerning bugs I can report two things at the moment.
First one is about shading. I used the model provided. Working in shaded mode, using a rendered mode first time, it looks like this.

When I switch the layers off and on, it disappears and everything is displayed normal in rendered mode right away. But it happens to occur again after working a while.

Second one is a little more difficult to describe for me. I think it’s related to installation issues because after restarting the computer today it doesn’t seem to be there anymore.
As far as I recall, I didn’t restart the computer after adding Pollination to Rhino.

First experience was a total crash of Rhino trying to use PO_SolveAdjacency first time.
This one went out as a report to McNeel

After restarting Rhino I continued on the model and when I followed the workflow like shown in the videos => Rooms, add Windows, add doors, everything went like it should.
But when I solved adjacencies right after creating the rooms, I wasn’t able to add Appertures anymore.
Rhino showed: Geometry type not supported. Please, provide breps or surfaces.

But like I said now I’m not able to reproduce this behavior.



Hi @martin6!

Thank you for the feedback. For the preview issue we are aware of it but since it is easily fixed by selecting one of the rooms we didn’t consider it as a major issue for now.

Let us know if you can recreate the issue again. I will also try next time that I install a new version and see if I can reproduce the error right after the installation. Are you using Rhino 6 or Rhino 7?

Hi @mostapha I’m using Version 7 SR8 (7.8.21196.5001, 2021-07-15)


@mostapha Some more things to mention.

I accidentally double clicked the Rhino Start icon. First thing was a message telling me my Pollination license is expired.
I clicked that away, maybe a bit to fast and also closed one of the windows without having a closer look.

In the remaining one the Menus where in English while the Toolbars read German.
Restart, everything in German again.

Then I started to Add Rooms. All but one of them where accepted, so had to fix it.
Your quality check seems to be very good. I really like that feature.

This worked so far and I started to edit the Room Properties. Almost done I realized some rooms weren’t perfect, so I started to rework them.
When changing the rooms most of them disappeared out of the list automatically, but some didn’t.
I’m not able to use the delete button? Unknown command: Delete?

I continued to work. Trying to fix the last room Rhino crashed completely, when I tried to assign the properties and most likely did click a little to often while waiting for response.

When I brought Rhino back to life out of 43 rooms only 9 still show properties.

I exported all 43 rooms to another file. All Properties are shown?

1 Like

You see this message if the Internet connection is blocked. Any chance that you have an anti-virus or firewall which is blocking the connection? The WIP license shouldn’t be expired.

Thanks! We just added another new command to help you also check the adjacency between rooms that are not fully aligned. That will be available in the next WIP release.

I’m not sure what might have resulted in this issue. @mingbo do you know why this might be happening?

Do you have the crash logs by any chance? In case you can recreate the crash is it possible to record short video so we can recreate it on our side?

I believe there have been some improvements on loading the rooms in Rhino. I will share the developer version of the plugin so you can try it with your model.

Thanks again for providing feedback, @martin6!

Internet connection was given. Firewall is windows defender only. No reports.

No in this case I didn’t report it because it contains data of which I’m not sure if I’m allowed to pass it on.
But I still have the relatively big Dump File.

First after restarting my computer this morning with 0.102.1 still in place, even in the original file all room properties appeared.
I’ll change my workflow and simplify the file a bit, so I’m able to reproduce and share more of the happenings.

Using the developer version doesn’t change much but I came across another, or maybe related Rhino crash which I can reproduce. In this case I removed the rooms face unfortunately prior to the last saving.
But anyway the room is still recognized.

Here is the file related to the video (129.3 KB)

It seems like there is still a way to go. Now with the reopened file the first floor living room is recognized as a 2nd floor toilet when selecting in the scene. When selecting in the list they are recognized properly.

Looks like after couple of times Rhino crashing it might be better to get rid of partially kept data, so I’ll restart the computer and have another look…

1 Like

Hi @martin6! Thank you so much for sharing the video and the report. This is gold for us. We will take a look into this and will keep you posted on the progress.

1 Like

Hi @martin6,

I looked carefully at your video, it seems you used “split” command for the top surface, which is not supported by our plugin now. You can see all supported rhino commands here: Getting Started - Pollination User Manual

In this case, you can use “SplitFace” command to a room! Here is a quick demo to show how to use it.


Thanks @mingbo! Can we develop a solution to ensure the commands that are not supported by Pollination will not result in crashing Rhino?

What’s crashing the Rhino was not because of unsupported rhino commands, it is inside the RoomManager. It is likely the RoomManager failed to select/highlight the geometry for some reason and crashed the Rhino. I have just added some checks for preventing it happening again.

@mingbo thanks a lot for keeping me posted and the hint regarding “SplitFace”.

Before I feed you some more incidents, I’d like to add something to @mostapha 's question regarding fail safe programming.
In case of mistakenly use of the “split” command it would be fine for me if the room just disappears and I am able to reintegrate the new Polysurface into the model.

In general I may have to say a few things about me.
On one hand I have deep respect for your decision “NOT to go after venture capital funds” with Ladybug
and on the other I struggle with the effort a grown up environment, like you intend to keep alive here, takes.

Diving into the ladybug world I realized how lazy I’ve become using primarily high end software.
So whats the point here.
OK fail safe programming should be always first choice.
But else my suggestion would be to consider if it might makes sense to place in the plugin easy accessible hints and explanations to the functions like you did on the Grasshopper canvas? Maybe to be switched on (for somebody like me) and off (for grown ups)?
In the long run you will have to compete with venture capital funds products anyway. So this might makes it easier for lazy people like me to have a steep learning curve and therefore stick to Pollination?

Working on with the model I faced a couple more things to mention.

I had no further problems reworking the model from scratch, getting rid of geometry mistakes and turning everything into rooms. I did this mostly in “wireframe” environment.

Only one crash occurred while I was just scrolling through the Energy Materials Library (or maybe Constructions, I’m not sure) without having done anything with it so far.
RhinoCrashDump_210814_Scrolling trough construction (174.5 KB)

I cannot reproduce it because in the meantime I upgraded to Version 7 SR9
(7.9.21222.15001, 2021-08-10

One wish regarding adding “Program Types” would be, to keep the last used Vintage: and Building Type: for next time of use. That’s more fun I guess.

Removing all the room properties once, I had one case of a room which kept its state without being shown in the list. Also it was only detectable as room using a mouseframe selection. With a direct click it appeared as a closed polysurface. Being insecure about eventual problems I deleted the object and rebuild it.

Hi @martin6, Thanks again for providing feedback.

We created a permanent link for the latest developer version of the Rhino plugin for our testers to make it easier for you to test the latest features and fixes. You can download the latest version from this link.

This is the behavior in the latest release. Here is what happened after I used split instead of SplitFace. @mingbo, should we add support for the Split command too?

If I understand your point here correctly, you are frustrated with the amount of work that it takes to learn the Rhino plugin because it is missing some help features? Or is it because of the UI? I honestly don’t think it has to do with taking VC money or not. It’s just that these plugins are quite new and still a WIP.

The goal of the WIP release is to understand users’ expectations to prioritize the next steps of the development. This is not a finished product and we are listening to everyone to figure out what we can do to make your experience better. I go through the list of your comments but please let us know if there is anything else on your list that we can do to make it easier for you. :grinning:

Do you have an example for this in Rhino? Is it about the options for each command or the UI? I believe you have already seen the documentation for all the Rhino commands here but you want something that is inside Rhino? All the options for every Pollination Rhino command is documented in the link below:

This was a bug that we also noticed internally and is already fixed in the latest version.

This should be doable but it’s for @mingbo to confirm. I agree that it will make the life easier to keep the last choice active.

This one is hard to debug without having an example but if it happened again you should be able to select the room and run PO_RemoveProperties command to solve this issue.

Thanks again for taking the time to test the plugin and sharing your thoughts. Looking forward to hear more and improve the plugin based on your feedback!

Looks like first time you got me wrong @mostapha.
I’m far from being upset with a WIP. I personally like the way things are set here and I’m also fine to move on with you step by step.
What I wrote was meant to take a look out of the perspective of somebody that doesn’t have the patience or ability to search a forum, dig for documentation or communicate with others.
I think you wrote somewhere in the Ladybug Discourse, one of your goals is to attract a wider range of people towards Ladybug. That’s where I tried to point to.

The Rhino UI is not very supportive for hints, unlike the Grasshopper UI.
But maybe a tab in the Pollination Toolbar containing the most essential tips and hints, or links towards them might be helpful?

There are already a couple questions in the queue concerning Ladybug and its surroundings waiting for me to have time to ask them in the right place.

What belongs here is the wish to change the color of a wall or ceiling or floor if it’s set as an Airwall in the Color by Boundary Condition view.
I saw I could uncheck Airwalls, but I think something more obvious might be better.

1 Like

Great to hear that! :slight_smile:

I like that idea very much! We might even be able to embed the HTML or MD version of the documentation in Rhino similar to Rhino’s help tab that links to different resources. I’m adding @jankivyas here to keep her in the loop.


We knew this will come up sooner than later! :grin: I don’t see it as a critical feature but agreed that it will be a delightful feature to have.

We have added a button on UI that redirects use to User Manual. Hopefully, this addresses the issue for now.