GEM file import crashes Rhino

Hi all,

Importing a GEM file with more than one room results in a Rhino crash. The RhinoCrashDump file created contains all the geometry but without the Pollination Rooms set up.

This occurs for:

  1. Gem files created through the Pollination Rhino plugin as well as through IESVE
  2. Very simple rooms, e.g. two cuboids with no apertures
  3. When the import process says the file is valid and has no warnings
  4. In my 2 room test, whether the rooms are adjacent or not

So, I’ve not included an example Gem file because it is every geometry if it has more than one room.

It occurs in version 1.0.0.0 but has also occurred in the last couple of releases.

Secondly (and not important), I’m not sure what is the best way to find out there has been a new release of the Rhino plugin. At the moment I go to Pollination Cloud App and hit the “download a free trial” button. It downloads the file “plugins_dev_PollinationRHGHInstaller-latest.exe” which doesn’t have a release number in the file name. I diff it with the last file I downloaded to see if the file has changed. Seems a release number in the file name, or on the web site, or via an announcement in discourse, would make this simpler. I’m probably being daft and missing something obvious though.

Cheers for the help and the plugin,
Liam

Hi @lharr,

That’s strange! I tried with two files generated from Rhino and Revit and they both worked as expected.

Here are the files:

PO_IES_VEModel.gem (6.8 KB)
from_rhino.gem (1.1 KB)

I’m one version ahead of you (1.0.1) but we haven’t made any changes to the core libraries between the two. Can you try these files and see if you can replicate the error.

If that is the case, then can you provide more information about the version of Rhino that you are using and its release. This is my information for example:

Version 7 SR18
(7.18.22109.5001, 2022-04-19)

We have to do a better job of providing notifications for new releases and not renaming the downloaded file. It is on our list!

Thanks for the files Mostapha. I still get the same thing - a crash and the dump file has the geometry but no pollination rooms.

Rhino release used was:
Version 7 SR17
(7.17.22102.5001, 2022-04-12)

I’ll try upgrading Rhino and the plugin and report back.

Hi Mostapha,

I couldn’t upgrade the Rhino version as Rhino tells me I am running the latest version when I search for an update. Which make me wonder why you have a higher release number.

Upgrading to 1.0.1 also didn’t work first time because I first launched the Pollination window. But if the Pollination window is not open, the GEM file import works without a crash.

I’ve done it a few time with and without the Pollination window open and it only works with the Pollination window closed. I guess it was the same for the previous releases. I never thought to try without the Pollination window open.

Thanks for your time.
Liam

Hi Liam,

Thank you for testing!

At least we know it only happens when the Pollination panel is open. Am I right that if you run the pollination command after you import the GEM file successfully everything works as expected? If that’s the case, can you share the dump file and the error log that comes with it so we can have a look on our end?

I can import the models with no issues with or without having the panel open.

Most likely because I’m using Service Release Candidate instead of the Service Release. I’m trying to catch the bugs if any before they hit the users. I doubt if an update will fix this issue but if you want to try you can change the setting under the update panel.

Yes, everything works as expected if I run Pollination command to launch the panel after the import has completed.

I’ll send the dump files via email as I can’t upload here as I’m a new user.

Regards,
Liam

Hi @lharr thanks for reporting this issue.

Have you tried to import the gem files that @mostapha attached above? Do they have the same issue when importing geometries with the Pollination panel open? Have you also tried to import other file formats, such as hbjson (here is an example) test.hbjson (120.9 KB)

Hi @mingbo,

Yes, I have the same issue with the gem files from @mostapha. Rhino crashes when the Pollination panels is open, doesn’t crash when closed. I tried your hbjson file, no crash with or without Pollination panel open.

Also, I have now tried this on two different PCs: 1) Threadripper Pro workstation with nvidia quadro graphics card, 2) Intel NUC with integrated graphics. I get a crash on both machines.

I don’t think this is related to the hardware, but I don’t know what exactly went wrong on your side.

Since you have tested it on two machines and have the same issue, it leads me to think about the user name on your machine. But it still doesn’t make sense that it doesn’t crash the Rhino when you open the Pollination panel after the importing.

Do you mind recording a quick video to show the process in case we missed anything?

FYI The windows installation on both machines started from the same system image about 6 months ago but have diverged since. I could also try a windows reinstall next week when I have some free time - just in case they share the same thing that is causing the crash.

Video recorded can be downloaded here: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Today, I found the gem file import crashed even if the Pollination panel was closed, as long as it had been opened previously in the Rhino session. Yesterday, I was sure it worked if I just closed the panel. But I guess I could be mistaken.

1 Like

Thank you, @lharr for uploading the video! Really helpful. :bulb: I can now recreate the crash!

The difference is that you are using the import command instead of the open command which is what we use. If you use the open command everything should work fine.

@mingbo, you should try the import to import the GEM file and you should be able to recreate the issue. Time to get it fixed! :hammer_and_wrench:

Hi All, this issue should be fixed in the new release for the import command.

1 Like

@mingbo, thanks, much appreciated