IES GEM import says "the geometry file may be unreadable or corrupt."

Hello @mostapha,

My download and installation was smooth for the Rhino plugin but IES-VE (v2021.4.0.0) is failing to import the .gem file. Tried a couple different exports from Rhino 7 and both said ‘The geometry file may be unreadable or corrupt.’ Can’t seem to figure out what might be going wrong during the export and import.


Hi @sborle, :wave: welcome to the forum.

Is it possible for you to share the Rhino model and the GEM file with me? If you can’t share the model publicly you can send it to me via a private message and I will have a look. It is really hard to know without seeing the files.

Thanks @mostapha ! and sure, I have no problem sharing the model here. I did try uploading the file in this response and it says I cannot upload because I am a new user. How do I send you the file in a private message?

Hi @sborle, can you try again now? You should be able to upload a file.

You can send me a private message by clicking on my image in the post and selecting the Message button. Similar to the image below.

Hmm. Still unable to.

Hmm! I’m not sure what’s going on. Can you upload it to Google Drive or another platform and share the link here? It should allow you to upload files now that you are a basic user.

Not sure why it still wouldn’t let me, but I just sent you a private message with a google drive link. Just so you know, I tried importing it a bunch of times, removing one context type at a time as I thought maybe its the context trees and buildings which wasn’t able to translate.

Hi @sborle, I checked your model. The issue is that your model is just Rhino geometry and not a Pollination model. In order to translate your model to IES you need to define zones/rooms and shading objects and then try to export them as a GEM file. I imagine your current GEM file should be an empty file with a header.

See the user manual to get started with the process:

Let me know if you have any other questions.

1 Like