Installation problem: rhino6 does not recognize the Ladybug path

Hi, everyone.
I used the Pollination Grasshopper single-click installer to install Ladybug Tools and Pollination,After the installation program is completed, when I open rhino6 / 7, the form of the displayed path is illegal,I want to know what caused this. My user name is in English and there is no space on the path.

LBT Plugin: System.ArgumentException: Illegal form of path.
System.IO.Path.LegacyNormalizePath(String path, Boolean fullCheck, Int32 maxPathLength, Boolean expandShortPaths)
System.IO.Path.InternalGetDirectoryName(String path)

Hi @omen

Could you try to open this folder:

Open and Ladybug.Loader.python with Notepad, and take a screenshot for me to debug? Here is what I found on my machine:

Thanks for your reply, mingbo.

Ok, here is a new Ladybug.RH.Loader.rhp file that you can use to replace the one on the above screenshot. There is nothing changed from the old version, but hopefully, this would provide more info about your error. (28.8 KB)

Hey everyone!
I have solved this problem by using an older version of the installer, but this program was sent to me by someone else, so I’m not sure exactly what version it is. This is really an amazing bug, thank you very much mingbo for your help!

I uploaded the installation package I used to github, which can be downloaded from here.

Thanks for your help Mingbo, although I don’t know what caused the bug, I managed to implement the software installation with the old installer.

Hi @omen could you try to download the latest version of the installer to see if it fixes the issue on your side.

I have made some improvements in the plugin, but I don’t know if it really solves the issue as we can’t recreate this issue on our side.

Hi Mingbo, before trying to use the old installer, I downloaded the latest version of the installer from the official website and tried to install it, unfortunately it still reported an error. Then I used the old version of the program and installed it successfully.

Hi @omen When did you download the installer? the new version was released last night.

11:30 minutes Beijing time

Hi Mingbo, I forgot to mention that I saw your message in the group chat on May 11, 2022 at 11:30 BST that a new version was released so I tried it, but it still reported an error. Then I tried Engineer Tao’s old installer and it installed successfully.

Today? That’s weird.
Could you check the version of the installer? From the error message, it seems from the old version.
You can right click the installer to get the property dialog, or from Windows “Add and Remove Programs”

The first picture is the new version I downloaded, and the second picture is the old version I installed successfully.



1 Like

Hi @omen, is this still an issue on your end with the latest version of the plugin?

Sorry I only saw your message now, there will still be problems using the latest installer on that computer, but after I switched to another computer, the installation was successful. I think it must be the computer itself that has a problem , not a problem with the installer.

I just have a call with another user who has the same issue and find the issue is because of this Grasshopper’s developer setting. For anyone who gets the error message like the following
System.ArgumentException: The path is not of a legal form.


You can use the command: GrasshopperDeveloperSettings and uncheck the “Memory Load …” option. This will solve the illegal path issue.