Login issues in pollination Grasshopper plugin


I tried to log in from the Grasshopper plugin in Rhino7, but it doesn’t log me in. I actually have both Rhino 6 and 7, I can log in from Rhino 6 but Rhino7 doesn’t let me. However I click on “login first” button, everything’s fine and it authorizes me through a browser, when I turn back to Grasshopper I still need to login and it doesn’t recognize me. what’s the reason? what should I do?!

1 Like

Hi @saminkamali,

Can you share a screenshot? Or ideally a screen capture? What is the error message that you get?

Actually there is no error message. It does nothing! It authorizes me successfully but when I turn back to grasshopper nothing is changed.
I deleted rhino 6 but still can’t login to access my project on rhino7.

I also reinstalled rhino 7 and pollination, but I still can’t log in! It works on rhino 6, which is not good because the other plugins I am using are just working on rhino7. If you help me out on this issue, it would be great.

Hi @saminkamali, do you have any anti-virus software that blocks Rhino or Pollination from accessing the internet?

Hi @mingbo, no, I don’t have any. I used the same laptop to connect to pollination on rhino 6, which was successful. But it doesn’t work on rhino 7. I even tried to create a new account on pollination but still cannot log in.

@mingbo and @mostapha, if you have access on the other end, would you please fix this issue for me because I am using this plugin for my thesis project, which is due by the end of June, and now I’m in trouble and rushing to find access to it, I need it to finalize my results.
I appreciate your consideration in advance.

Hi @saminkamali, there is not much that we can do about this issue at this point until we can find the source of the error. The transaction to pass the authentication information from the browser to the Rhino plugin happens on the client-side (in this case your machine) and we don’t have much control over the process beyond logging the information and looking for errors.

The fact that it works with Rhino 6 but not Rhino 7 makes it even more strange and the process is exactly the same. We are working on this issue and we will keep you posted. Thank you for your patience.

Hi @mostapha thank you so much for your complete response. Looking forward to hearing back from you.

Hi again, @mostapha. I think I found the reason; it’s the firewall! I have to turn them off then I can log in successfully!
Thanks for all of the support.