Natural ventilation is not taken into account


already observed this with another model, but since it appears again here is what I get out of Pollination.

Ventilation is set but not calculated
Same simple model out of a GH workflow

Hi @martin6,

I did a quick test with a room that has ventilation controls set, and exported it to the hbjson file. After checking the data in hbjson, all seem correct to me. Could you share a sample model that doesn’t take ventilation control into account?

ndl2y4wq.aez.hbjson (44.8 KB)

1 Like

Hi @mingbo just created another run to be sure in the Validation Folder
Run GR 034. The model if needed is in the Rhino folder.

Information seems to be given. Maybe it is an issue with post processing in GH?

@chriswmackey, can you check this case?

Hi @chriswmackey after quite a while I’m able to work with the PO Plugin again.

But I can’t get useful results at the moment.

Model out of GH => Cloud simulation => Natural Ventilation works
Model out of PO => Cloud simulation => No natural ventilation at all in the results
Model out of PO => Import to GH processed through AFN => Cloud simulation => Natural Ventilation appears in the chart but no significant values are shown

1 Like

Hi @martin6 ,

Sorry that I didn’t see this earlier. How are you generating the SimulationParameters? Are you certain that you are requesting the outputs that are needed for Natural Ventilation Gain/Loss?

I don’t have any issue getting it on my end with the latest development version:

Also, when you say “Model out of PO” do you mean the Pollination Rhino plugin?

Yes @chriswmackey I allways use the settings out of the single_family_energy_model. Only every now and then I ask for surface temperatures too.

Yes I do.

Just tried another model with the latest plugin

Results run 022_039 here …while loading I recommend to get a cup of tea/cafe and do some stretchings… :grinning:

I also like to add here I’m a loyal fan of your theme “Making simulations “not wrong” enough to be practical”. Just newbee for the moment insecure and when I understand I’ll work my way back to simplicity.
But if you know any shortcuts yet, I’d like to know about? :wink:

OK back to the topic.
At the moment I manage to get Natural Ventilation with a work around in GH

1 Like

Hi @martin6 ,

Thanks for clarifying. I’ll admit that I haven’t gotten the chance to test natural ventilation in the Rhino plugin yet but there are two things that have to be done in order for natural ventilation to happen in the simulation:

  1. The Room has to have a VentilationControl object that dictates the control parameters for when the windows open.
  2. The have to be apertures on the room that have a True is_operable property in order for them to open.

@mingbo , could you clarify whether both of these have been exposed in the Rhino plugin? I will try to test when I get the chance.

And thanks for the kind words about the axiom I have on my profile. I can’t claim all of the credit for it since the mathematician George E. Box who was the first to say, “All models are wrong. The practical question is how wrong do they have to be to not be useful.” It’s just a good reminder that modeling is an art and different design questions often merit different modeling tactics and levels of detail.

Hi @martin6 and @chriswmackey,

Both settings are available in Rhino plugin.

I am going to un-assign myself from this issue for now unless there’s an issue here that I am not seeing. I guess it just took some time to find the right dialogs to assign natural ventilation in Rhino.