PO_EnergyMaterials command disappears after opening the Grasshopper plugin

Hi @mingbo

I don’t know if what I have to say is still related to the topic, or if there is a solution already?
If it’s better to discus things under a new thread, feel free to move my answer.

Installed latest version, start Rhino and Grasshopper. Load Energy Materials using double click to the plugin while Manager stayed open. All materials appeared. Close Manager and restart Rhino.
Everything gone again besides the one Materiel manually created.
Open Grasshopper, Load Materials using Bake. Close Manager. (not totally sure if I did something else before, maybe just closed Grasshopper) Pollination Tab disappears.
Restart Rhino, still no Pollination Tab. Tried to use command line
Command: PO_EnergyMaterials
Unknown Command: PO_EnergyMaterials

Any suggestions what to do next?

1 Like

Hi @martin6,

I would like to replicate your issue. Please, correct me if I am wrong, this is your issue: Pollination plugin is not loaded on your machine after the procedure you described. If it is this maybe we can have a separate thread about it.

Could you check/confirm that the plugin is not loaded?
Settings / Plugin-ins and seach for “Pollination”

Could you guide me step by step with screenshots in the new discussion?

Thank you,

Hello @antonellodinunzio

at the moment it looks like this.

I also tried to ask for the CheckGeometryAdjacency Tab. It just disappeared after the click.

When I restart Rhino the plugin isn’t loaded but the CheckGeometryAdjacency option is there again, but without function, like described above.

Hi @martin6,

CheckGeometryAdjacency is part of Pollination.RH, this is the reason why you also have issues with it.

I am not able to replicate your issue for now. But a good idea is to start a clean test. Could you try to delete your current Pollination Rhino plugin first and install it again?


  1. Close Rhino
  2. Run the installer and follow the procedure to uninstall the plugin.
  3. Close the installer without performing the successive step. Make only sure that the uninstall process is done.
  4. Run Rhino to check if the Rhino plugin is still there (also if it is unloaded), or Grasshopper Pollination plugin. If so, go to %APPDATA%\McNeel\Rhinoceros\packages\7.0 (if you have Rhino 7 for Windows) %APPDATA%\McNeel\Rhinoceros\packages\6.0 (if you have Rhino 6 for Windows) and delete the Pollination folder
  5. Run the installer again to install the plugin from scratch

After that I kindly ask you to perform the same procedure that generates the issue and document it, maybe recording it or taking some screenshots of the steps you perform.

Thanks for your patience,

That’s how it looks after Step 1. to 3.

Grasshopper Pollination is also still there.
Completed step 4. - 5.
Restart, Pollination is available.
Went through my prescribed procedure, step by step, but this time I encountered no crash.

Only the disappearing Materials matter comes up again?

After installation from scratch the previously added Material is there.

Materials added with double click restart all gone.
Next all Materials Baked

Next time I start Rhino, all but one Material gone again?

@antonellodinunzio, thank you for your kind support but I’m not able to reproduce the crash. Maybe the clean install was the reason?

OK this time I worked on 'till I had defined and assigned a construction and a construction set.
Save - Close - Open
All Materials are there right form the start? :thinking:

1 Like

There was a minor issue in the process of uninstalling the plugin that it wouldn’t clean all the files. This has been fixed!

@martin6, do I understand it correctly that in the latest version the problem has been resolved?

Hi @mostapha

concerning the crash I can’t say for sure because I used all the time the same version

Regarding the Materials I think there still needs something to be done.

1 Like

Thanks. The issue that I mentioned is fixed from version - but since you manually removed everything you basically did the same using the older version.

I leave that one to @antonellodinunzio! :slight_smile:

Hi @martin6,

Could you confirm that you use a workflow like this? If yes, I would like to debug it with your LBT materials if you can share them.

To Rhino

Materials you get from LBT exist on runtime and at the Rhino Model level. It is necessary to save the file to get them in a next session.

Please, let me know.


1 Like

Thank you @antonellodinunzio for this demonstration.
The Video might be a good add on to your Pollination documentation?

In my case I used the same workflow, except for file save.
That’s the reason why it didn’t work.

From what I’ve understood so far, if there is a need for custom Material,

  • it can be defined it in the Plug-in
  • I can Import own Materials from Grasshopper
  • or load a 3dm with predefined Materials
  • Materials I change or add in the Plug-in exist only in the file (when saved) and part time in the runtime environment
  • there is currently no way of passing a material from one Rhino instance to another?
  • also no way to pass a Material from the Plugin to Grasshopper?

To be honest this doesn’t sound very practical at the moment?
I hope I didn’t miss something here.

What if you save these material in the user library? Then they will be loaded to all the instances of Rhino.

To be honest, I couldn’t figure out how to do this with 1.2.0, yet.
With the legacy version I know how to do it.

1 Like

@chriswmackey and @ayezioro, can you help me out here about this question. Thanks!

Sure @mostapha !
I suggest, to start, to check the samples folder in the food4rhino installation file.
In the honeybee-grasshopper-energy-master\samples folder there is a file creating_constructions.gh.
Start there and let me know if you need more help @martin6.

1 Like

Hi @ayezioro

Thank you for the tip. I had a look at the file, but nothing new to me in it.
The way to create materials is more or less the same like mine.

The question remains how to write those materials to a library?

When I use the Legacy “Honeybee_Add to EnergyPlus Library” component it’s written somewhere. But no link to the new 1.2.0 environment?

I put together and example file you can use.
It defines materials, constructions and construction set and writes them onto the LBT libraries folders (just notice their location is fixed).
Be careful when writing the definitions that there are no files with the same name on the libraries locations. You might override!!
Hope this helps,

03-E_Dumping_Mats_Const_Sets_4_Discourse.gh (116.8 KB)


Yes @ayezioro that’s the final puzzle piece I needed

I also read this thread some time ago…

Sometimes understanding English and lots of other things is challenging quite a bit.
Your file makes it way easier to move ahead.

I also wonder if I might ask a bit to many questions at the moment?
I can see a way now to work with USER CUSTOM CONSTRUCTIONS and MATERIALS.
When I think about how to organize them I quickly reach borders in the given structure telling me it’s maybe satisfactory for the moment, but not in the long run.
Well that’s maybe a discussion in a new thread or to be delayed to later versions?

Thanks one more time for your support

I’m sorry that I didn’t see this earlier and thanks for showing @martin6 the ropes, @ayezioro .

I don’t know what you are talking about here, @martin6 , and you would have to elaborate for us to be of any help:

Both the Rhino plugin and Grasshopper plugin load up the objects saved in that standards folder and that’s the way that you should store objects that you need to access from multiple files and plugins.

There are other ways to pass constructions back and forth between the Rhino/Grasshopper plugins that store the objects in the local memory of the Rhino/Grasshopper document. The 4::Rhino tab that’s included with the Rhino plugin installer should give you some other ways of sharing objects between the two.

@chriswmackey I replaced the answer here