Pollinate Component Error - Runtime Error


I created simple model (single zone) to run through Pollination workflow. I’m getting stuck on the last step i.e. sending recipe to Pollination w/ “Pollinate” component. I have recorded the runs I’d like to iterate through and connected them to the component but I encountered this runtime error, "Object reference not set to instance of object."

Has anyone else encountered this?

Snip and .gh script provided below for reference.

Shared_Daylight_SingleZone.gh (192.9 KB)

Hi @victorbrac, there is a SmithGroup component in the script which makes it hard to test on my side. Is that important for testing the workflow? If it is not, then let me know and I can try it as is.

@mingbo, is there a way to get a better description of the error here? Do we log these cases in the log file?

@mostapha - feel free to remove the SmithGroup component. I built this from scratch using LBT components so it should not require any SmithGroup components.

To clarify, which SmithGroup component do you see causing an issue?

It is called OpenLogger.


That’s not required. It’s just part of our .gh template. However, after deleting all of these components, I still encounter same error.

1 Like

Hi @victorbrac,

After changing the recipe to one that I can run on my projects, this works on my side with no issues: Pollination Cloud App

Can you try to reload the recipe and re-run it?

If that works, it was a glitch on our side because of the SDK login process. If it doesn’t then let me know and we can get on a call to debug this. I imagine it should work with no issues. :crossed_fingers:

P.S. You probably want to name each and every model based on the input parameters.


I did some additional troubleshooting.

  1. Could the issue stem from the private job that I created? Is my account restricted to only public jobs? I switched back to a public “demo” job folder and was able to run in Pollination.

Test private folder that did not work

  1. After running in demo folder, I was not able to reload results into Grasshopper. However, I was able to load results from AEC workshop in November. Any ideas on why I cannot load the recent results? I am able to see the job on Pollination cloud and even view the Visualizations.

Link to Pollination cloud job
Pollination Cloud App

Fully agreed! But I wasn’t sure how to do this for each run. I did try naming job and subfolder in Pollinate component.

Hi @victorbrac

A private project shouldn’t be a problem, as we are still under beta testing, and you can have unlimited private projects if I remember correctly.

I am able to load your job back to Grasshopper. When you say it is not loading the job, what was the error message? From your screenshot, it seems the job’s status is “Created” after 1 hour and 40 mins waiting. This might be an issue that our server failed to update this job’s status. Maybe @antoinedao could be able to provide more details. But when I check this job, it has been completed.

Mostapha meant assigning a customized name to HB Model, which is the first label that you highlighted in the “Build HB Model” group.

Thank you for the response and providing the example snip. The issue was that while I could see the job was completed on Pollination web page (e.g., same link you provided), the “run” from “Check Job Status” component was not loading into grasshopper canvas. However, when I went back to test again this morning, I see “Completed: [05:08 [5]”. The “[5]” is new today, this was not present yesterday. I am now able to load into grasshopper per your workflow that you shared in snip.

I’m not sure what changed between yesterday and today to enable loading the file into grasshoper.

Thanks for clarifying.

I tested multiple times yesterday and was unable to run recipe to private job. However, today it worked.

After the job has successfully run, how do I navigate to private job location and so I can load results? I tried search and advanced search and don’t see how I can change location to victorbrac/explorationgrant.

Hi @victorbrac,

You can use advanced search, and use your username “victorbrac” as the owner to search for your private projects.

Alternatively, you can always copy the path to the job in a panel: