Revit to Rhino to GEM to IES-VE Adding Thickness to Shading Elements

I created a model in Revit, exported to Rhino, made a few changes, then exported to an IES-VE GEM file. The GEM file is then imported into IES-VE. But I’m having some geometry problems with the shading.

Previously when working without Revit, exported shading elements would be single planar surfaces in IES-VE. On my current project, the imported model in IES-VE has each shading element extruded by the thickness of the element in Revit. These thickness do not appear in Rhino. What’s even more confusing is that shading elements around the windows I’m generating in Grasshopper also have a thickness applied to them. I would ideally like single surface shading elements, instead of extruded one.

Within IES-VE, the shading elements are being imported as Room objects and made into Local Shade. It’s possible this may be an IES-VE setting I’m missing too.

Hi, @justinshultz - the thickness is by design and has been added as part of the changes in this release.

Why

From the user feedback, we realized that IES ignores the single planar faces for suncast if they have zero volumes, and are exported as single faces.

Here are the shades as faces.

And here is the same model when it is modeled as a closed volume.

How does the Rhino plugin work

The logic of the Rhino plugin is to group the shades that are created from a closed BREP together as a single volume with no extrusion. If the shades are created from separate faces then it extrudes them to avoid the issue that I mentioned above. Let me know if it is not clear and I can record a longer video. I also recorded this video when we developed the feature that should clarify how the process works.

I knew this day will come, and because of that, I made the value for thickness optional in the code. We didn’t expose this in the Rhino plugin but we can do that. Let me know your thoughts, and we will improve the implementation.

Shades from Revit

If the shades are coming from Revit and they are generated from a closed geometry the same logic applies to them.

Thank you for the explanation. I appreciate your insight and thought process. Some of the building shades don’t have the group id and each surface are individually being extruded. I’ll regroup them in Rhino.

What is the default thickness you assume?

And does IES-VE have a min thickness? Couldn’t we make it just a few mm and still get the volume geometry needed for suncast.

1 Like

It is currently set to 10 cm. I was worried about generating tiny faces in the model.

I’m not sure about that. If you can give me a better number that you know works in IES I will be happy to change the default value. It is a pretty straightforward change.

Actually, we can probably ask @douglasbell007 about it. Douglas, see above :point_up_2: Do you have any suggestions about the minimum thickness?

Working with the Pollination to GEM process recently I found the 10cm thick shades a little too large - off the top of my head I think in the ballpark of 10mm would be my preference.

Another potential issue is that IES starts to perform slowly with lots of shade elements. With something like border shades for windows generated by HB number of shades / surfaces can quickly jump up and make the Suncast simulations in IES significantly longer. For border shades you could look at joining them and then applying a thickness to give a single shade element in IES, but for louvres or similar I can’t easily think of a good way to avoid slow down.

Thank you, @charliebrooker for your input. It looks like the best option is to provide a UI in the plugin to adjust this value and set the default to a smaller number. It seems both of you are in agreement on the default value being 1 cm.

1 Like

I changed the default value to 1 cm. The change will be released with the next release of the Rhino and Revit plugins.

Thanks for highlighting this issue and providing a work-around via Pollination!

This reads as an IES bug to me. To the community’s knowledge, has any one pointed this out to IES?

From my understanding, if planar surfaces are ignored in Suncast then their impact is ignored in loads and energy simulations. I suppose natively built shades in IES would not have this problem, but shades imported through other interoperability methods, including the IES Sketchup plugin may!

Also, to reduce shading faces for the sake of speed in IES, wouldn’t it make sense for IES to support single planar surfaces?

1 Like

I have brought it up with the IES team but I’m not an IES user/expert. If you can give it a try, and confirm it, we can submit a new ticket for this. They have been really helpful with accommodating our requests.

I totally agree. I like the fact that it pushed us to introduce the concept of grouping the shades when possible but it will be great to keep them as faces and don’t extrude them if possible.

Hi All, there is a quick solution to this. Once in the VE if you select the shades group and hit ‘Heal Geometry’ this will resolve this.

1 Like

Hi @douglasbell007, thanks for responding. Can you clarify what ‘Heal Geometry’ will resolve? Will IES-VE correctly interpret and use single surface shading elements if Heal Geometry is used? Should @mostapha remove the 1 or 10 cm thickness applied to single surfaces so that we can instead use Heal Geometry on those surfaces in IES-VE?

2 Likes

Hi, @douglasbell007 - Thank you for the solution. I think I can go through the process manually, and compare the GEM files to see what happens between the two but if you already know what happens there we should be able to automate the process during the export and remove the manual step.

1 Like

Hi, @douglasbell007 - I went through the process to see what does the Heal Geometry do but the exported GEM file after using the command and the input GEM file are identical. ¯\_(ツ)_/¯ - I imagine the change is not geometrical and has to do with some settings that are set inside the IES file. Is that correct? What would be the best practice here?

1 Like