Rhino plugin Installation Error: no such option: --python

Hi guys

Sorry to revive this post, but I just wanted to install the newest rhino plugin (version 1.18.0), but when I run the installation file, I get this error

I then thought, that I might need to uninstall the current version first, but the I get this error

If I go to the folder it’s looking for, it’s apparent that the folder doesn’t exist on my computer. I only have the pollination_revit folder

Also, as you can see on the second image, I have 2 idle PO.Revit plugins on my computer… So it’s all super messy. I just opened rhino and can conclude that both the rhino and the grasshopper plugins are gone, but PO.Revit still works fine.

Hi, @labrosse - Sorry for the error. Can you share the installer log file with us? You should be able to see the error there. They are under the %TEMP% folder and named as installbuilder_installer_{an integer}.log.

Sure, here you go

installbuilder_installer_30500.log (215 Bytes)
installbuilder_installer_24408.log (1.2 KB)
installbuilder_installer_22016.log (1.6 KB)
installbuilder_installer_5364.log (1.2 KB)
installbuilder_installer_11500.log (1.6 KB)
installbuilder_installer_38820.log (1.6 KB)

I tried a couple of times today, and can see that the logs very, so you’re just getting everything :wink:

Thank you, @labrosse! This the error:

no such option: --python
There has been an error.
Error running C:\Program Files/ladybug_tools/python/python -m pip --python "C:\Program Files/ladybug_tools/python/python.exe" install -r "C:\Program Files/ladybug_tools/lbt/requirements.txt" --no-index --find-links "C:\Program Files/ladybug_tools/lbt" -I --no-warn-script-location: 
  C:\Program Files\ladybug_tools\python\python.exe -m pip <command> [options]

no such option: --python
Exiting with code 1

Can you run this command from the command line? It looks like for some reason the installer on your machine has an older version of pip.

"C:\Program Files\ladybug_tools\python\python.exe" -m pip --version

Thanks! That is the problem. It should be version 22.3.1.

@mingbo, do you know why this might be happening? I can’t think of a good workaround here because the installer overwrites the Python installation every time. :confused:

Hi, @labrosse - @mingbo pointed out that in your case the pip is loading from the other installed Python under AppData folder. That should not happen but there is a reason that this comic exists! ¯_(ツ)_/¯

In any case, try running this command to update the pip installation, and then try to re-run the Pollination installer. This should resolve the issue for now.

"C:\Program Files\ladybug_tools\python\python.exe" -m pip install --upgrade pip

@mingbo, we should probably use the full path to the pip file in the installer instead of using the python -m pip command.

Thanks guys, that did the charm

Got an error, but I guess it isn’t relevant as the installation worked, right?

Installing collected packages: pip
  Attempting uninstall: pip
    Found existing installation: pip 22.0.4
    Uninstalling pip-22.0.4:
      Successfully uninstalled pip-22.0.4
  WARNING: The scripts pip.exe, pip3.10.exe, pip3.7.exe and pip3.exe are installed in 'C:\Users\eyx826\AppData\Roaming\Python\Python37\Scripts' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
Successfully installed pip-22.3.1
1 Like

Hi @labrosse I have just released a new version of the installer. Would you mind to download and test it on your machine?

Hi @mingbo

Just ran the installation without problems. Thanks!