Room Height Adjustments Not Exporting Correctly

Hello @mostapha,

When I make a change to room limit offset, I find that while value may update in Revit Pollination UI, the exported height is unchanged from the previous value. For example, I changed from 15 ft to 8 ft limit offset but dragonfly model still exports as 15 ft height.

Also, I am unable to get the “pull up height” feature to work and successfully rid model of inconsistent extruded heights. Alternatively, I’ve tried turning off floors and ceilings as room bounding and fixing limit offset to known floor to floor height but I still find inconsistent heights across floor plate.

Hi @victorbrac! Did you already send us this model? It looks like you have already unchecked the pull up height option. In that case, this looks like a bug to me. Thanks for reporting the issue with great documentation as usual! Cheers. :raised_hands:

Hi @victorbrac! I had a call with @ksobon and now I know why this is happening. We will change this behavior so it should work as expected.

What is currently happening

The Revit plugin tries to find the bounding box of the room based on the aperture to ensure all the apertures will be bounded inside the room wall. This change adjusts the heights of the rooms which results in inconsistent room heights. It basically overwrites the limit offset that is set by the user.

What is the proposed solution

  1. We will add a new column in step 4 that allows you to set the floor to floor heights for extruded mode for every level.
  2. We will remove the columns that won’t affect the calculation of the room in extruded mode from step 6.
2 Likes