The Eto.Forms Application is already created error

Hi Mostefa,
The pollination Revit plugin is not runing.
I got this message yesterday.

I think you forgot to attach the error message.

Hi @aziz! You are using an older version of the Revit plugin with the older licensing. This has been discussed before. Try to install the latest version of the plugin and it will resolve the issue.

I 'm on the last version of Revit 2022. with the last update

Hi again Mostepha,
After installing the new release, I got the error message.
I m using Revit 2022.1

Hi @aziz, I meant downloading and installing the latest Pollination plugin for Revit not the Revit itself. You can download it from our website.

Hi Mostapha,
It’s what i have done. the last realease that i download it’s plugins_dev_PollinationRevitPluginInstaller-latest

Hi guys

Has this issue been resolved? I just downloaded the Revit plugin today and got the same error message.


I know that @ksobon addressed a similar error here, but it’s not completely the same case I guess

I still waiting for the solution. I have montienned this problem to Mostapha but never got the answer.

Hi @labrosse and @aziz, I didn’t reply since I’m really out of ideas for this one at the moment. We are preparing a new major release with some changes that might help with this issue. I will let you know when the new version is available so we can try to fix this for you.

cc: @ksobon

1 Like

@aziz quick question. This error states that the Eto Application is already created, which tells me that somehow it’s trying to create another one. Pollination plugin is not doing this initialization twice, so I am guessing something else initialized Eto App already. What other Revit plugins do you have installed? First thing from top of my head is something like Rhino Inside Revit which would be the only thing potentially using Eto.

Just to confirm, please try uninstalling other plugins (or just removing them from the Addins folder) for a moment, seeing if Pollination works. That would confirm for me that it’s a conflict with something else.

1 Like

To add to @ksobon comment, if you are using RIR what version of it are you using? That will help us to try to recreate the issue on our side.

Hi Mostapha
Here my version RIR 1.5.8101.24585

1 Like

Hi @mostapha I have also received this error. I downloaded the latest Revit Plugin directly from your website before trying a new install. It seems that something in the new install is getting caught when starting Revit. The installation appears to be successful with no issues. But when launching Revit, I receive the same error message. Let me know when it is fixed!

Hello all! We just released a new version of the Revit plugin with an updated UI and updated dependencies. As usual, you can download it from this link: Pollination Cloud App in case you want to give it a try.

I’m not sure if it will resolve the problem though. Did you try to follow @ksobon’s suggestion and remove the Rhino.Inside temporarily and see if that changes anything?

On my end, I have both and when I select the Options button I see this:



But I can start RIR with no issues and also use the Pollination plugin at the same time.

@mingbo, is there anything that we can do to ensure the ETO library that comes with Pollination and the one that comes with RhinoInside are in separated namespaces?

Hi Mostapha
I still have the same problem

Unless we compile our own version of the Eto for Revit plugin, I can’t think of any other solutions in this case. Can we invite someone from McNeel to check this issue?

Depending on how hard this will be, it might be a good solution actually. Similar to what we had to do for the JSON library.

I can! But I need to make sure our assumption of the source of the problem is right before getting them involved.

@aziz, @labrosse and @justinshultz - did any of you try to remove/uninstall Rhino.Inside.Revit and see if that resolves the problem?