The Eto.Forms Application is already created error

Hi Mostapha,
I removed it since ur last message, it’s about 2 week ago. so it’s doesn’t resolve the problem.
I had befor WIP 8 and remove too.
I removed Pollination plugin for Rhino too. yesterday and reinstalled it today, I got this message
“Failed to activate thie licence. please retreive a licence from the Pollinatio”

I disabled the Rhino.Inside plugin but still received the error.

We recently increased our security checks at our company and Carbon Black might be flagging it without notice.

I’m not really sure though based on the messages I’m receiving.

1 Like

Hi guys.
I just uninstalled both RIR and Pollination.Revit, and then installed the latest version of the Pollination.Revit but got the same error as last time :confused:

image

1 Like

Hi All, any resolution for this error? I am also running into this and can’t run in Revit:
image

Hi @mishasemenov, unfortunately we have not been able to recreate this error on our end to be able to debug it. I will document this internally to make sure we find the solution for it sooner than later.

Hi guys

I just uninstalled Pollination, reinstalled Revit and then installed Pollination again, and now it works! Or at least I think so. The Pollination tab hasn’t been available in Revit until now.

However, my 14 days trial period has expired though I haven’t had access to the program yet, so I can’t see whether the functionalities are intact. Might it be possible to get a new trial period on my account so that I might be able to see whether we are interested in the Revit plugin? :sweat_smile:

image

I should also add, that I asked our IT guru to install the revit plugin as well on his PC, but he did not get the Eto error. So he wasn’t able to see whether this error was caused by our servers or something of the sorts. The only weird thing we saw was that I have two Pollination Revit Plugin programs on my PC when we look at apps and features on my PC.

If I uninstall pollination, only one of them will disappear. If I try to uninstall the other (with the oldest time stamp) I get the following error. I checked that there is no pollination_revit folder under users on my PC after uninstalling the first one. So that is kind of weird. I wonder whether this is the case for the rest of you, who had the Eto problem??

image

1 Like

Hi @labrosse,

Yes! This is on us. We will need your trail key to extend it. I’ll start a private message to help you with this issue.

@mingbo, do we have a clean installation executor for the Revit installer similar to the one for Rhino and LBT?

Hello everyone! We made a change in the process of loading the Eto library which should hopefully solve this problem. Can you download the installer from this link and give it a try.

If this one works, we can have a new official release. Thanks in advance! :pray:

1 Like

Hi Mostapha,
It’s work fine now.
Merci !!!

1 Like

We have a new official release that should resolve this issue. It also comes with a very nice new step to easily and quickly select the context item by item instead of selecting the faces.

Credits go to @mingbo and @ksobon for figuring out the issue and fixing it!

3 Likes

Hi Mostapha,
My trial period has expired :frowning:

Hi @aziz, that’s on us. If you go to %appdata%\Pollination\logs folder you should be able to find the expired trial ID in the log files. If you can message that to me I can extend the trial period for your account for 14 days.

You can also share your computer name with me which will help me to find your trial ID on our side and extend it for 14 days so you can give the plugin a try before making up your mind.