The PO_Extract2DPlans also doesn’t work properly

Just checked this one

The PO_Extract2DPlans doesn’t seem to do what it is supposed to.

The chosen Room disappears after the command ! (Does this make sense?)

and the result is in the wrong place (just pasted the Room back in the first picture to be able to show the source).
Looks like the command is having difficulties when there is not a flat top of the room?

Hi @martin6,

This PO_Extract2DPlans has an option for deleting input geometries, and the default is set to true. If you want to keep the original geometries, you could change “delete inputs” to false.

Meanwhile, this PO_Extract2DPlans keeps the max height of the bounding box from the input geometry, which is used in PO_Extrude2DPlans to extrude the 2d drawings to solid breps.

That said, if your original geometries have tilted roofs, then it will not be kept after PO_Extract2DPlans and PO_Extrude2DPlans.


Thank you @mingbo
for being patient with me, sometimes missing the most obvious things. :smirk:

Now I really get how this workflow is meant to be.
Just had no need yet to use it beyond extracting. And if then I didn’t need the same room height.
To be precise I extruded the PO_Extract2DPlans curve with native Rhino tools

Still there is a little wish remaining.
Is it possible to keep the last used setting of DeleteInputs= Yes or NO for the next time the command is used?

Actually I didn’t think to spend much time with this topic, but being at it I had a look, stumbled over some other topic and wonder still if I’ve done everything right.

The behavior of the update component is strange, isn’t it.

Edit: Ah sorry here is the file
2D Plans.3dm (203.3 KB)

1 Like

Yes, I am working on it.

For “PO_MatchRoomProperties” command, it is designed for matching properties between rooms, not for pure Rhino geometries. But I see the point that why you did this. I will improve this “PO_MatchRoomProperties” command by adding a check and converting those non-room geometries to room objects first.

1 Like