Unkown error Adaptive comfort map

The adaptive comfort recipe runs till the end and it gets terminated. Attaching the snapshot of the error. The error log shows nothing.

One more update, Even UTCI map simulation fails the same way. I have installed the latest LBT version also.

Hi @asisnath! Thank you for reporting the issue. As you can see in the error message it says the run has been killed which indicates it’s more likely an issue on our side.

We have recently implemented a limitation on the number of parallel tasks which seems to have some side effects including the random failure of simulation steps as you reported above. @antoinedao is looking into this issue and will let you know the outcome!


Hello again, While working on a different project I came across a weird behavior of simulation of Adaptive model in simulation.
This is the floor of an apartment model i was trying to generate adaptive comfort.

I tried simulating it twice it continuously failed after 24 minutes (both cases) with multiple errors as attached below. The same model simulates successfully for radiation, energy and daylight. This conforms the energy part of comfort recipie is not an issue.

But when I simulate individually each Flat comfort recipe works without issue.

Do we have any limitation attached to larger models?

Hi @asisnath :wave:,

Thanks for reporting your issues to us. I think you are encountering two separate failure mechanisms in this thread. One of these should now be fixed and not appear again, the other however might be trickier to get rid of.

  1. Multiple Errors with logs like “Bad Header!” in them

    • Fixed :white_check_mark:
    • This was caused by a bug in our cloud run scheduler which has now been fixed. The error was that task output files were not reliably saved, which lead to corrupt files being used as inputs, and thus “Bad Header!” would appear
  2. Killed error

    • Not Fixed :x:
    • I am not certain what is causing this error so will need to reproduce it on my end, which I will aim to do this week to have a clearer answer for you.
    • I strongly suspect that it is being caused by the CPU/Memory limits imposed on the tasks being executed on the cloud. Our current limits are of 1CPU and 3.5GB of memory per task. It is possible that the comfort map function uses a lot of memory in order to load the energyplus SQL output file.

Do these responses help you better understand what might have gone wrong in the runs shown above?

Thanks for bearing with us as we iron out the last of the “big bugs” on our platform! :raised_hands:

Thanks @antoinedao for the fix. Really appreciate that. I will reset the run and give you the feedback. For second case I will try to reduce the grid points number and give it a run to see if reducing grid counts helps running the simulation smoothly. :+1:

1 Like

Hi again @asisnath,

I just noticed one of your runs failed and retried the “run-energy-simulation” step 5 times… :upside_down_face: I think this might be caused by a bug on our end. I think you’re using ladybug-tools/adaptive-comfort-map:0.3.0, it might be worth trying it again using ladybug-tools/adaptive-comfort-map:0.3.1 which might have fixed that bug.

I’ll double check this issue and the other one mentioned above first thing tomorrow morning (GMT timezone) :raised_hands:


Thanks for getting back on this @antoinedao . You are correct I am using 0.3.0 version of adaptive comfort. I will do as you say and try with 0.3.1.

1 Like

Hi @antoinedao . I tried again with Adaptive comfort version 0.3.1. The previous error was not highlighted this time but still gave one error without logs. It ran for 5hrs and terminated.

Only this error was highlighted

Hi @asisnath :wave:

I have found the cause of the bug you encountered (it was an issue with our cloud workflow scheduler) and have fixed it. You should now be able to run your adaptive-comfort-map simulation :raised_hands:


Thank you @antoinedao. Will rerun it immediately.


2 posts were split to a new topic: UTCI Comfort map calculation step fails with no logs