Use Radiance folder with Pollination recipes for large models

Hi guys

I just ran an annual daylight simulation and got the following error. I can’t seem to figure out the problem as nothing is written in the log

My first guess would be that the grid wasn’t added correctly to the HB Model, however, this doesn’t seem to be the case.

Is there a more transparent error log on your end?

/Mark

This is mostly likely a memory issue. How many sensors do you have in the model? Can you try to save the models as an hbpkl first and use that as the input instead of using the model directly.

Hi Mostapha

That does make sense as I am working a very large project imported from Revit. So even though I have cleaned the model manually, it is not as clean as a model created specifically for the purpose.

I just tried using the compressed model as input as you suggested, but got the same error


image

The model includes 7543 sensor points in total distributed over 64 sensorplanes. I use a grid density of 0.5m, which is fairly coarse. Most planes have 150-200 sensor, but there is one with 300 sensor points.

Hi @labrosse! Thank you for trying.

Well, that’s something that Pollination should be able to handle! :upside_down_face: The challenge is we have to pick the memory allowance based on a typical job and then add some extra space for jobs that can be larger. As usual, we will get out layers like this one. At some point, we should be able to expose the memory allowance on the UI so you can edit it based on the size of the mode.

Another solution that can save us from these cases is to update the recipe to work with a Zipped Radiance folder. I tested the model locally and after being translated to a Radiance folder and zipped is only 12 Mb.

image

@chriswmackey, I know we have discussed this before. What do you think about implementing it sooner than later?

P.S. @labrosse, I understand it is not ideal but I want to make sure that you know that you can run the same simulation locally too. That should be a workaround to help you move forward until we find an optimal solution. Let me know if you need help running the model.

Agreed. As I said, it really only takes me a day to implement this and it now seems like it would help out several people. I’ll take a hiatus from the other stuff I was working on and just get this done today.

I would guess that the reason @labrosse 's case is failing isn’t because of the sensor grids (7,500 is not a lot). Rather, I’d guess that it’s because of a lot of detailed geometries. I bet even the unzipped version of the radiance folder is a lot smaller than the HBJSON just because there aren’t any energy properties in it. So I agree using the rad folder should hopefully work.

Hey @labrosse ,

All of the changes to enable you to input a Radiance Folder to the annual-daylight recipe have been implemented.

Just run the LB Versioner component and restart Rhino. Then, you should now be able to simulate your model like so:

Just make sure that you use the HB Model To Rad Folder component to translate the Honeybee Model to a Radiance folder. And only use the latest version of the annual-daylight recipe that is NOT USING THE -viz TAG. The -viz part isn’t set up to interpret the radiance folder input yet.

I am pretty sure your case should all run successfully, especially if you use the new minimal_ option on the “Model To Rad Folder” component, which should make the output Radiance files even smaller.

4 Likes

Hi Chris

Thanks for prioritizing the problem and updating the component this quickly!

I have started a run, however it seems to behave differently than usually. The simulaiton has now been running for 36 minutes, but has only come this far.

If I remember right, my last (functioning) simulation on the case took 6-9 minutes in total. But for now I will just let et run, so that we can se the outcome, but if the HB Model to Rad Folder component makes the simulation time this much longer, the cost per simulation in CPUhours will increase exponentially compared to my last run :confused:

UPDATE

The total simulation time was 38 minutes, so my guess that the simulation was much further at 36 minutes than was displayed on the website. But that is a very minor problem.

My next simulation on the same model only took 6 minutes however.

Thanks for the help guys :+1:

2 Likes

Hi @labrosse! Thank you for the update. Yes. It can take some time for cloud resources to be available but you don’t get charged for the wait time. You get charged for the compute time which as a matter of fact is actually very similar between the two jobs that you submitted.

I know that our current UI is a bit confusing but hopefully this table can show the difference. See the values under Duration Hours and the CPU Hours

Also, you may want to make sure that you do not breakdown the sensor grids too much to get an optimized distribution. You can do that by setting the minimum number of sensors per grid.

P.S. Well done, @chriswmackey! This will be a very helpful feature both for large models and custom folders.

3 Likes

Great, @chriswmackey!

I just did a rendering with a 1.16 GB tensor tree bsdf file, that I previously could not run due to memory issues. The zipped folder is 267 MB.

2 Likes

Hi @chriswmackey and @mostapha !

I also have a very large model (complex geometry and about 4000 points). I am running direct sunlight hours analysis and ran into the same problem. I’ve tried your solution here of translating the HoneyBee Model to a Radiance folder but then plugging “folder” into “_model” of the simulation component it turns red with

  1. Input parameter “_model” has the file path without [“json, hbjson”] extension.

The other day I successfully ran a different annual daylight analysis on another much smaller model without this problem.

Any pointers??

Thanks!!

Hi @jaclu,

We haven’t updated all the recipes yet to support a Radiance folder as an input. I know that it is on @chriswmackey’s list to do it at some point soon.

Good to know! Thanks @mostapha for such a quick reply

1 Like

Sorry that it took so long for me to address this but I can finally say that all of the latest Radiance recipes on Pollination can now accept the Radiance folder as an input in lieu of a HBJSON or HBPkl file.

Let me know if you face any challenges while using this in your workflows and thanks for pushing us to make this happen.

4 Likes

Thank you @chriswmackey ! we’ll be sure to test it out at the next opportunity