Using user defined LBT resources

Hi @mostapha,
I mean the same resources that i defined already for LBT (saved as json files, or idf in some cases), for instance materials/constructions/ schedules, etc.
Indeed are those in the resources folder.


1 Like

Hi @ayezioro,

In this version, Rhino plugin is only loading libraries from:

  1. resources\standards\honeybee_energy_standards
  2. resources\standards\honeybee_standards\energy_default.json
  3. resources\standards\honeybee_standards\radiance_default.json

I think we will adding support for loading user’s libraries in later version.

However there is trick that you can use for now: you can bake a honeybee model from Grasshopper with this new component. It will automatically add all your custom constructions/program types/modifiers that assigned to the model to Rhino.

1 Like

Will give it a try.
Thanks @mingbo !

I downloaded the latest version of Honeybee but I couldn’t find the suggested component. Have they been taken out?

I have a model created in grasshopper with parametric variables (different window-to-wall ratio, different orientation, glazing types…), is it useful to use this component in this case?

The model component is part of the Pollination Rhino plugin which you can download and install from here:

Since the materials I added in the Materials Manager are gone with the last WIP update installation, I found this tread.
It answers some of my questions, but not all and raised some new ones.

@mingbo where are added materials located? There is no Source mentioned.
I tried to find an added material in the files you mentioned here.

But wasn’t successful.
Is there a way to preserve them manually?

I also tried to import materials Bake Pollination Modell without much luck.

Failed to bake: This is an invalid VentilationOpening object! Error: Invalid value for FlowExponentClosed, must be a value greater than or equal to 0.5.

When I add a test1.json file to the honeybee_energy_standards Folder it isn’t recognised. Why?

I found a way to import materials using “Pollination Material”

But the added materials are gone the next time I open up the manager?

Only one material I created using the add option in the manager stays there.

1 Like

Just as a note. It would be helpful if the last set filter: Name, Type, UValue,… stays after closing-reopening or editing operations.

OK next crash trying to Add window construction. (177.5 KB)

When I open Construction Manager => Add Window the response I get is :
Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.

Translates roughly to:
Aim wasn’t defined properly.

Restarting Rhino I lost all my specific definitions of materials and constructions.

I think in this case I have to move my project from Pollination to Grasshopper until the material and constructions section is working better. Being able to define materials and constructions is unfortunately essential for it.

@mingbo please keep me posted when it’s worth a try again.

Else I have a wish regarding the Construction Section. It would be great if it’s possible to define material thickness there.
It’s rather much effort to jump back to Materials and define a concrete variation with the thickness desired and then back to Construction to fit it in.

Thanks @martin6 for reporting this issue, I am fixing it now. I have also enabled loading user’s libraries to the Rhino plugin. I will let you know when a new installer is ready later today.


Hi @ayezioro @martin6,

You can download the latest developer version of plugin from this link . It loads all user’s libraries, and fixed the bug that @martin6 reported above.


Hi @mingbo,
Thanks for the update. A couple of things:

  1. When i go to the Model Resources icon and ask for the Energy Constructions, i get the following in Rhino’s command box:

The type initializer for ‘Honeybee.UI.ConstructionViewData’ threw an exception.

All other options open their respective window for editing.

  1. I still don’t get how to use my own defined library elements. For any option i choose from the Model Resources i get defaults and can’t see from where i can add/see my libraries. Any pointers on this? Hope is not a (very) silly question.

Just to say what i did before posting this: I uninstalled Pollination; Installed Pollination from the installer you posted above; Open Rhino/GH and update with the Versioner (to be sure i have the latest); closed Rhino; open Rhino.


p.s: This is what i get (partially) when i ask for the “About” button in RH:

Pollination.RH, Version=, Culture=neutral, PublicKeyToken=null

  • C:\Users\ayezi\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\Pollination\1.0.0\Pollination.RH.rhp
    Pollination.UI.Rhino, Version=, Culture=neutral, PublicKeyToken=null
  • C:\Users\ayezi\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\Pollination\1.0.0\Pollination.UI.Rhino.dll

@mingbo thank you for the updated installer. Unlike @ayezioro I could load all the user defined library except the schedule part.

When I clicked on Schedule nothing pops up. On command prompt it says “Object reference not set to an instance of an object.” For your info , I am using Rhino 7 SR9.

Hi @ayezioro and @asisnath,

Thanks for testing and reporting issues. Could you please attach the user’s construction library file here for me to debug @ayezioro ? and for @asisnath could you please attach the schedule file here as well?

There might be some issues with what you defined in user’s library. Please send them to me via private message if you don’t want to make them public.

Hi @mingbo,
Just sent you by email.

Hi @ayezioro,

There is an issue with your IS_Const.json file.
Here is the error I got when I run the following command. But I can load them to GH. I asking @chriswmackey to look at your files.

C:\Users\mingo\ladybug_tools\python\python -m honeybee_energy lib to-model-properties

honeybee_energy.cli.lib - ERROR - Loading standards to properties failed.
'ScheduleRule' object has no attribute 'schedule_type_limit'
Traceback (most recent call last):
  File "C:\Users\mingo\ladybug_tools\python\lib\site-packages\honeybee_energy\cli\", line 635, in to_model_properties
    sched_tl = [sch.schedule_type_limit for sch in all_scheds
  File "C:\Users\mingo\ladybug_tools\python\lib\site-packages\honeybee_energy\cli\", line 636, in <listcomp>
    if sch.schedule_type_limit is not None]
AttributeError: 'ScheduleRule' object has no attribute 'schedule_type_limit'

Hi @ayezioro and @asisnath,

The new developer’s installer has been released, please download it from this link and try it again with your user’s library.

Note: please backup your user’s library folder, the installer will override the folder.


Hi @mingbo. I am happy to say this installer have removed the error. I could now load custom user data for all parameter. Even custom schedules now loads perfectly. Thank you for your patience and time to debug it. :+1:

1 Like

Thanks @mingbo,
It works fine at my end too.

1 Like

2 posts were split to a new topic: PO_EnergyMaterials command disappears after opening the Grasshopper plugin