Using user inputs with white space makes the run fail

Hi,
Since i think this discussion was lost in the process of moving the pollination from the LBT discourse, i"m trying to link it here again hoping there is a “solution” or advice to the issue.
I didn’t tried again after i posted there the last status of the simulation (running forever).

Thanks,
-A.

1 Like

Hi @ayezioro, can you try it again now? I just ran it again with your input files and everything ran as expected. You can check the run here: Pollination Cloud App

I just realized that it doesn’t have a handler for Grasshopper and it only return the results files. This is something that we should address on our side so you don’t have to do the post-processing yourself.

cc: @chris

Hi @Mostapha,
I tried but no success this time either.
I saw that your run took something like 2 minutes. I canceled my job after 6-7 minutes.


I notices also that the run_id gives an error when i tried to check what is going on:

I’m assuming i’m doing something wrong then but can tell what it is.

Thanks,
-A.

Thanks @ayezioro! @antoine, can you have a quick look at this one? Can it be the Wea path again?

Hi @ayezioro, @antoine checked the logs before submitting them to Pollination and it looks like you have a user input which has a space in the name: Grid size.

This is something for us to fix and make it more flexible but for now if you just remove the white space or use a _ instead it should solve the problem. Grid sizeGrid_size

Let us know how it goes.

I knew this is something i did. Thanks @mostapha and @antoine.
Now i see results and this is great. I can move on.
Something to report that is not fully consistent: I removed the white space in the input of the User Inputs component. But the output was still showing the name with the space. At first i didn’t notice and sent the simulation. Needed to cancel it. Then i disabled/enable the component and it worked. Why is not consistent? Because i inserted another User Inputs component and this one does the update on the name as expected.

Thanks again!!
-A.

This is a question for @Mingbo! Most likely we’re missing triggering a new event when you rename the input for the component.

I just added checks for invalid input names, it will be available in next release.

Inputs without real data connected won’t be checked, since it won’t be collected. But it will complain if there is a data added.

1 Like

Thank you @Mingbo !!
God is in the details …
-A.