Your Model is invalid for the following reasons: object that is missing

Hi all,
does anybody have an idea how to figure out more about this face?

Your Model is invalid for the following reasons:
A Face has an adjacent object that is missing from the model:
Face “Face_c84e054f-8591-440d-9ae4-d5852472943b” was not found in the model.
Matching adjacent constructions could not be verified because of missing adjacencies in the model.
Face “Face_c84e054f-8591-440d-9ae4-d5852472943b” was not found in the model.

In the meantime after some alteration of the model I get a message telling me which instance is missing Face_c84e054f…

A work around for the at the moment not working search is, if the model is passed to the grasshopper canvas it can be found using HB Label Faces

grafik

But since there is a adjacent face I really wonder why there is a missing one too?

1 Like

Looks like things are more weird than I thought.
since I remodeled the Room missing a face
another untouched one is missing a face now?

If that’s a running gag it might be better to quit changing rooms. What do you think?


Asking for faces which are supposed to be deleted?

Is there a difference between deleting something when the Room Selection Mode is on On or Off?

Hi @martin6,

As you can see, the initial issue has been resolved and now the Rhino plugin reports the name of the original face which has an issue.

The error message is structured as {display_name}[{id}]. This is the first step to make it easier to find the problematic face.

I agree that we need a better solution to be able to find the faces by id or display name. @mingbo, can we add a command for now until we have a UI to help with this?

Yes. In Room selection mode, when a Rooms is selected all the apertures and doors for that room are also selected. This means any command will be applied to all those objects. For instance if you move the room it will also move the aperture of the room. The same is correct for the delete command.

Hi @mostapha

Yes that is true. I found the face missing another face using the feedback. It is shown as green rectangle

But he face reported missing doesn’t exist on any visible level. That is my point here.

And when I remodel the Room missing some face then there is another one missing in the model which wasn’t reported before?

Thanks for the clarification.

I see! The error is because the other face exist in the boundary condition of this face. If you remove the boundary conditions or change the boundary condition for this face to Outdoors then the error should go away.

If that’s not the problem then I will need a model to test on our side.

It’s uploaded to the Rhino3D Models Project on Pollination cloud

Thank you @martin6! @mingbo, I added you to the project so you can access the files here once you get a chance to have a look.

I was just having similar issues, I found that PO_ResetBoundaryConditions, then PO_SolveAdjacency fixed the issue and returned a ‘gratz!: Model is Valid!’
Dunno if that’s helpful at all but I found that out just now.

Validating Model JSON ...
Python re-serialization passed.
Model geometry and identifier checks completed.

Your Model is invalid for the following reasons:
Face "Face f2609[Face_f2609a5e-5b69-4271-9111-015ed8ae1ed7]" has an adjacent Face that is missing from the model: Face_0f342c66-8993-4c9e-9f80-053e702c4bec
Face "Face 5dd27[Face_5dd27866-3369-4a9c-b4cc-9f4321fd824f]" has an adjacent Room that is missing from the model: Room_d47ce51e-30a2-447b-8fad-17074941ca98
Matching adjacent constructions could not be verified because of missing adjacencies in the model.  
Face "Face_0f342c66-8993-4c9e-9f80-053e702c4bec" was not found in the model.
1 Like

Things have improved quite a bit with 0.121.2.0
After Solve Adjacency I receive this message

I can get rid of it, if I turn the AirBoudaries into walls and do Solve Adjacency again.
Then the model is valid.

I change the properties back to AirBoudary and don’t use the Solve Adjacency command again.

Not sure if that’s correct?

1 Like

Hi @martin6! An AirBoundary is only valid when it’s adjacent to another AirBoundary. That’s why you get the error.

Do I understand the question correctly? Or are you suggesting that the Rhino plugin doesn’t solve the adjacency correctly for the air boundaries?

Hi @mostapha

Looks like it might be related to this Post


I had a look at the IDFs of former simulations of this model. The “Innenwand” is there.


If I drag it to the construction the model becomes valid.

To summarize all this.
I’m still not 100% sure if I missed something modeling, trying back and forth to get the model valid. (Insecure because if I made these mistakes before, why weren’t they detected earlier?)
At the moment it looks like the feedback I get out of the Solve Adjacency Command is working fine.
Was able to solve anything :grinning:

Hi @martin6, have you tried with the new developer’s version and still getting these issues after solving adjacency?

1 Like

@mingbo I can’t reproduce the problem with the Airboundaries in this topic anymore since I didn’t save all model states.
But for the later part of this post…

…most likely I am the source of the problems.
I’m sure you did a great job, the checks are just fine and helped me to solve anything in my model.
Thanks

1 Like

Sorry I have to dig this up again,
there is no solution to this yet.

Today I tried a couple of simulations with a model which was good before.
First I thought it doesn’t work because of the ventilation settings I changed.

Finally I checked the day before valid model with Validate Model again and got this response

A whole room missing. Not appearing in the Room manager.
Refresh the whole thing => still the same
Wasn’t able to find it neither with @antonellodinunzio 's tool nor the @mingbo way.

Didn’t save my file. => restart computer

Room is still missing. Marked all rooms in the view => Solve Adjacencies Room appears back in the Room manager?!

Check model with Validate Model again same message like first time. Room is missing but this time it remains in the manager and can be searched.

A missing room searchable, present in the Room manager… wow.

@mingbo placed the still unsaved model H100_018 there…

1 Like

Hi @martin6, is this still an issue? Please let us know if the issue remains.