"An error occurred when copying the files to the job folder"

I’ve been trying to test out the plugin by myself for a better understanding of how things work. I’m trying to follow along with what you’re doing in this video that you shared, but I believe there have been a couple of changes since you recorded it.

Here’s where I’m stuck:

As you’ve done in the video, I’m doing this on top of the annual daylight example included with LBT 1.2.0.
Is there something I’m missing?

Hi @pmArchitect,

Thank you for reporting the issue. did you try to update your Ladybug Tools installation using the versioner component? And then update the sample file?

I suggest to start with using daylight factor recipe which should run fine if you use the latest version of the plugins.

Yes. The process has changed a little bit. I just shared the video that I recorded with you via Google Drive. I found a bug is sorting the results while recording the video and that’s why I didn’t post it publicly. The bug has been fixed but I didn’t get a chance to record a new video. Will do after Tuesday this week. Meanwhile the video should help you to get started.

1 Like

@pmArchitect I think you uncovered a bug caused by spaces in the file names used. I have sent an update to our servers so if you try the same script again it should work.

Thanks for reporting back and letting us know how you get on :raised_hands:

1 Like

Thanks @antoine! I can confirm that this issue has been resolved.

@pmArchitect , here is the sample file that I used to run the simulation. You have to re-load the recipe from your project.

02_two_rooms_annual_daylight_pollination_complete.gh (63.6 KB)

And here is the run of Pollination.

1 Like

Sorry to reopen this thread, but today I’ve sent 2 jobs (108 cases each) and I’m getting the same error reported at the beginning of the thread:

  1. This job is [Failed]. If job is scheduled but not started, please check it again in a few seconds;

I can say for sure that i don’t have blank/white spaces, I’m running the last LBT and pollination versions.

Any ideas?

Hi @ayezioro, can you share the link to these jobs?

One is this and the second is this.
Thanks @mostapha !

Thanks! This is one probably for @mingbo since the file that is referenced in the error message hasn’t been copied to the project folder.

Hi @ayezioro, I cannot think of any issue with this missing model, and I also tried to recreate a model with this name and it works all fine with this recipe. Here is my job and model.

Would you be able to recreate this issue only with one run with “Ctxt-0_Off_5-Floors_VF-4” model?
Would it be possible that this Ctxt-0_Off_5-Floors_VF-4 is an invalid HBModel and it failed to be saved?

Hi @mingbo ,
This is weird indeed. This is the link for the only one run.
The case was completed.

Hi again @mingbo,
I kept trying to make this work. I recreated the 108 cases, since i made an error before (all cases used the same model while each one has to be different).
I’ve sent to pollinate a couple of jobs with 3 cases only (see this and this). They succeeded and were completed.
Then i tried to “dare” again with the 108 cases, but, unfortunately, it failed with the same “symptom” as before (missing model, as you defined it). This is the link.
I’ve sent a job with the supposedly missing model and it run fine (see this).
So now, as before, i’m completely clueless and out of ideas what is it that i’m doing wrong.
Thanks for any help you can provide.

Hi again (#2) @mingbo,
I have some updates, good news and bad.
The good news are that i’ve sent again the jobs while i’m at the university. Both jobs went through and are running now.
So what happened? I looked at the Pollination folder in the C:\Users\USERNAME\AppData\Local\Temp\Pollination and noticed that there is a large folder named prepareArtifacts containing the 108 hbjson files. That made me wonder and i remember that the failed jobs were sent from my home. And those are the bad news. What are the internet settings i have at home that make the uploading of thee files to succeed? I don’t know. The same thing happens when i try to use the LB_Versioner. It never succeeds while at home. What i do is using the cellular hotspot (if i can’t wait to do that from the university).
If you happen to have any idea how to overcome the internet issue i’ll be glad to hear. Probably other people can face the same issue. I’ll try t send a single case job from home to see if it goes through.
In any case right now the jobs are running fine (hopefully).