Apertures problem while model export

Hey all,

Just wondering if anyone is also having difficulty exporting apertures through the latest Revit-plug-in. These are two examples with the same Revit model for two different versions of the Revit plug-in.



I wonder whether I am missing something important in terms of model export steps for the latest plug-in.


Oops! We thought we improved the parsing! Sorry about that! :face_with_diagonal_mouth:

I’m not sure why this might be happening. Can you share the model with us to recreate the issue? This is most likely the result of the changes that we made to improve parsing the apertures that were missing from the model.

Hey Konrad! This is an interesting case. Hopefully, there is an easy fix by filtering the input curtain wall/window.

Has this been solved? I’m having similar issues, Revit export is not capturing aperture

Hi @rwdhope,

From your screenshot, it has been exported correctly. It looks like that either the layer for apertures is off in Rhino or you have hidden the geometry. Try running the show command.

The apertures were off. Thank you it works now

This has been addressed for most cases in the latest release (v2.154.2). There might still be edge cases that we will address in new topics.