Clicking on HVAC button raises an error in Rhino 8

I seem to be getting this error now when clicking the HVAC button inside of the room properties panel:

It seems to work when first opening Rhino/Pollination, but then proceeeds to throw up this error, seemingly at random. Ie - sometimes it works and others it throws the error, and I’m not quite sure why.

1 Like

I suspect we use a different Python command here, and we forgot to set the env to ensure it uses the Python 3.10 that is shipped with the installer.

This is causing quite a few issues and keeps happening, has there been any progress on this issue yet? I have just tried re installing pollination but I am getting the same error.

Sorry about the issue, @milog! We have been focusing on some major refactors for parametric studies last week. We will have a closer look this week. Meanwhile, is it possible for you to use Rhino 7 temporarily until we fix this issue?

Hi @milog, I am not able to recreate this issue on my side. @mostapha do you see this error on your side as well?

Hey @mingbo ,

I can recreate it on my end:

Here are the steps to recreate it:

  1. Use the Rhino 8 ScriptEditor command to open the script editor. Once the libraries have been created, restart Rhino.
  2. Open a Pollination Rhino Model that has a HVAC template system defined in it.
  3. Run the PO_HVACManager command.

FYI, @milog . A quick workaround for this issue is to just delete the following folder:


Then, after you restart Rhino 8, you should be able to use the PO_HVACManager command without issues. Of course, this is not a great long-term solution and Mingbo should hopefully be able to fix this soon.

1 Like

Hi all, thanks for the input. Unfortunately deleting the .rhinocode folder is not an option right now as we are developing some custom python components at the moment, which live inside the site-packages folder, which in turn lives inside of the .rhinocode folder. There is no rush, this bug is not causing any significant blockers, it just causes rhino to crash occasionally.

1 Like

Ok, thanks @chriswmackey. This is helpful, I was trying to use the Python 3 component in Grasshopper, and it could not trigger this bug.

1 Like

Fixed, it should be in the next release.


Hey @mingbo ,

I realized that I had to make a slight correction to step 2 to recreate the bug. I think you need to have a Pollination Rhino model open that has a template HVAC system assigned to it in order to recreate the bug.

Here is a .3dm file that you should be able to use to recreate it:

Nevermind. Glad that you were able to recreate it!

Yes, yes I used your sample model that I got previously. Now I use this model for all tests:>