Energy boundary conditions - Revit to OpenStudio

I am new to pollination and I am tying to explore its capabilities. I have exported a Revit model to OpenStudio through Pollination with solve adjacency set to “Full”. It seems that OpenStudio can recognize internal walls as “surfaces” which is good but the interior floors are recognized as “outdoor” surfaces (presented in blue) which is not correct.

If I don’t set the adjacency to “full”, the internal walls will be considered “outdoors” and the internal floors will be “adiabatic”.

Is there a way to fix this? I would like the internal floors to appear as “surfaces” (in green).


Hi @ammarde, Welcome to the forum!

The fact that you see 3 options for solve adjacency tells me that you are using an older version of the plugin. Can you try to install and test the latest version?

I ran a test on the Revit sample model, and it solves the adjacencies correctly between the floors.

If it still didn’t work for your model, can you check and ensure the faces between the two floors match as expected? You can also export your model as HBJSON or share the Revit file with us for debugging. Thanks!

Thanks Mostapha for the quick response. I am actually using the latest version (2.172.0), I only see two options for solve adjacency (Full and None).

How can I check and ensure the faces between the two floors match as expected?

Is there a way to share the file privately?

The easiest way is to check the model inside the viewer in the Revit plugin.

Yes. I just sent you a private message.