Error when running pollination recipes

I just started to use pollination to run simultions but I couldn’t use any recipe from pollination since it kept showing the same error as “1. Exception has been thrown by the target of an invocation. From HBModelToJSON(Handler-csharp)” with different recipes I tried. I use Rhino 7 with Pollination GH Plug-in Please help me to solve the problem to use Pollination plug-in.

Pollination (56.0 KB)

Hi @alanylchou,

Welcome to the forum, and thank you for reporting this. We had two other cases that reported a similar issue but I have not been able to recreate it on my end.

@mingbo, my best guess is that this is a dependency issue that is happening is the user installs the Grasshopper-only installer. I’ll test it now and report back.

OK. I was able to replicate the issue by using the Grasshopper-only installer.

This tells me that we are missing one of the dependencies from the Grasshopper-only installer that is included in the Rhino installer.

1 Like

Hi @mostapha, from the log file, it seems the HoneybeeSchema.dll is missing and I can confirm that from the GitHub Action log. I am looking into this issue now.

1 Like

Fixed, it will be available in the next release today.

1 Like

Thank you, @mingbo!

@alanylchou, v1.48.8 is available with the fix.

@mostapha It works for v1.48.8 now, but I did got another issue when running the recipe on local machine as shown below.

The component ran well on cloud but it got an error message “value can’t be null and set Set Helper.ExeCommandHandler first!” with local machine.
Pollination (56.5 KB)

1 Like

I think I know what’s going on. It might be a bug introduced during the refactoring of supporting the Rhino 8. I am checking it now.

Just an update, the issue has been fixed and it will be in the next release.

1 Like

Hi @alanylchou, Thank you for letting us know. I should have done more testing.

Can you try to download the latest version (v1.48.9)? We should have it right this time.

@mostapha it works now. Thank you for your help.