Expected honeybee-energy Measure. Got <type 'str'>

Hi Folks,

Any idea why I’m getting this error:

  1. Handler-python: Expected honeybee-energy Measure. Got <type ‘str’>.
    when trying to use this Open Studio measure?


FYI It does work with the local “HB Model to OSM” component.

1 Like

Hi @patrykwozniczka, What version of the Pollination Grasshopper plugin are you using? Can you try to update to the latest version and try again?

I’m using Pollination.GH, Version= Is there a newer version available?

1 Like

@mostapha @chriswmackey is there anything else I could try to fix this (I’ve tried upgrading LBT plugin)?

Or are you looking into this and perhaps it’s not on my side?

Hi @patryk_wozniczka, It is not on your side. I just pushed a fix and a new version for the recipe: Pollination Cloud App

Try to reload the recipe and it should work. The version is 0.3.4.



@mostapha that fixed it for me but just an FYI: now I’m getting the same error when nothing’s connected to the “measures_” input:

And the annual-energy-recipe requires the same fix I think:

Hi @patrykwozniczka, Thank you for reporting the issue.

@mingbo will check the issue with the default value.

@chriswmackey, will do a new release of the annual-energy-use soon. The combination of these two fixes should resolve this issue.

1 Like

Hey @patrykwozniczka,

A new installer (130.5) has been released with fixes for the above two recipes. Could you please try the new one and let us know if it works as expected?



The annual-energy-use recipe has also been updated. So we should now have full support for measures through the Pollination Grasshopper plugin.


It works as expected. Thanks folks!

1 Like