Failed to write Model to drive

Morning! I am trying to export a honeybee model of an office/conference building with the Revit plugin and at the end of the process I keep getting the error “Failed to write Model to drive.” Another odd thing is that the 3D preview of my spaces isn’t loading, even though all the values for them seem correct… the preview window just stays blank.
Any idea where I can start on troubleshooting this @mostapha ? Thanks in advance for the help :slightly_smiling_face:

Hi @mishasemenov! Glad to have you back on the forum, and sorry for the issue.

Looking at the UI, you are not using the latest version of the Revit plugin. I would update the plugin first. That might help.

Other than that, you can always check the logs under %appdata%\Pollination\logs\Debug.log. That should tell you what is going on.

Thanks @mostapha , I am actually having trouble getting the latest plugin to install, keep getting this error:

Hmm. This is the first time I have seen this.

  1. Are you running the installer as an administrator? If not this might be because of permission issues when the installer tries to write the files to the Program Folder.

  2. Can you go to the %temp% folder and see if there is a log file named installbuilder_installer_{A number}.log? That should include the logs from the installer.

    If I have to guess the signal that kills the process might be coming from an anti-virus or a firewall on your machine that doesn’t like the pip install command to run locally.

    Another guess is that your machine runs out of memory which kills the process but that is unlikely.

Sorry that it is becoming harder than it should be! :expressionless:

We tried installing as an admin and as a regular user but both resulted in the same error. And I am not seeing logs in the general temp folder–should I be looking somewhere else?

There had been an issue with the firewall blocking this earlier, but we had it turned off…

I guess I will have to do some more testing on Wednesday when IT is back. If you have any other ideas, let me know :slight_smile:

Hmm. I’m not sure. Unless @mingbo has a suggestion.

Do you have a similar issue when trying to install the Rhino plugin? That can tell us if it is related to the installer or if your system is flagging our installers.

Hi @mishasemenov - were you able to fix the installation issue?

So, we reran the installer a couple of times and the third time was the charm… everything got updated correctly. Woohoo!

However, the geometry 3D preview is still not working and the same error of “failed to write Model to drive” is appearing :frowning:
Here is a copy of the log:

Debug.log (133.5 KB)

Hi @mishasemenov,

Sorry for the delayed response. From the error that I see:

2023-07-06 11:42:43.2792|INFO|pollination_logger|Processed CLOSET in 0.3101994s.|
2023-07-06 11:42:47.5838|FATAL|pollination_logger|System.NullReferenceException: Object reference not set to an instance of an object.
   at Pollination.Revit.Utilities.DocumentUtils.GetFilePath(Document doc)|System.NullReferenceException: Object reference not set to an instance of an object.
   at Pollination.Revit.Utilities.DocumentUtils.GetFilePath(Document doc)

I suspect this is why it is happening. Did you save the files as central? Or do you have it open as a temporary detached file?

If that’s not the source of the issue, then we will need access to the Revit file to be able to recreate the issue on our end.

Hi Mostapha, Hi everyone

I’ve followed the conversation and tried all the suggested solutions, but the issue remains unresolved. I still get the message “failed to write the model to drive”.

• We could’nt find any file called installbuilder_installer_{A number}.log in the temp folder.
• We have re-installed pollination 3 times as an administrator, helped by CCleaner
• It was tested on simple save and central folder.
• It was tested on all types of export folder

It is strange because we’ve tried running it on another computer and it works perfectly.

We have tried on several versions but actually i have the 2.1622.
I’m on Revit 2023.
I need to export on GEM file.

If you have any advices it would be very helpfull !
Thank you in advance for your help and for your time.


Hi @quentindepas, Sorry for the issue.

This tells me that the issue is either specific to this system or to this file. Can you export a GEM file for any other model? Can you export the file as an HBJSON? If you can export it as an HBJSON can you share it with me via a private message?

Thank you!