Get Model button doesn't work after adding the HVAC

Updated to 1.40.3 now. I’m running into an issue where the PO Model object is unable to “Get Model” if I’ve applied an hvac system through the hvac manager (PO_HVACManager). It seems to work fine if I apply it through grasshopper via the HB DetailedHVAC.

Hi @tylermcw, Thank you for reporting the issue! :neutral_face:

Can you share a simple model with us to recreate the issue? Thanks!

It says I can’t upload any files, I’m too new

I updated your profile. Can you try now?

100 m2 box B.3dm (503.7 KB)

1 Like

I imagine this might be happening because of a change in the schema.

Hi @tylermcw,

Thank you for sharing the model. I don’t see any HVAC systems assigned to the rooms.

I also can get the model with no issues.

Is this the right model? Can you help me to create the issue by following a few steps? Thank you and sorry!

the model provided dos not have an hvac but it was the model that “broke” after applying one. I’ll provide two more models now, one is currently working with FCU added via the OpenStudio library and the other one is broken (on my end) with an ironbug VAV reheat template added to it.

test_model.3dm (228.4 KB)
test_model_ib_hvac.3dm (272.0 KB)

WORKING: test_model.3dm
NOT WORKING: test_model_ib_hvac.3dm

not sure if this will be helpful, but the way I’ve worked around this is by loading the model directly using a python node


Hi @tylermcw, thank you for the additional info. I missed the Grasshopper screenshot. For some reason, I thought the issue was with the Pollination web page or apps. I documented the issue for @mingbo. We should get back to you soon.

Thanks @tylermcw for reporting this issue, it is indeed a bug, and I just fixed it.

1 Like

This is fixed in version 1.40.7 that was released today. Thank you @tylermcw for reporting the issue, and @mingbo for fixing it.