Issues Selecting levels, rooms that don't exist being counted and issues processing rooms

Hi all.

I’m having an issue with selecting levels from the “Levels” tab of the pollination window, whereby some levels seem to be automatically selected, and when I try to deselect them and select others, they just reappear. I tried 2 methods of getting around this:

  1. I have tried selecting only the levels I was, and then deselecting all others using the tick boxes, and the proceeding. (These selected levels did not appear and again only the few auto selected ones did)
  2. I have selected all levels available, with the intension of previewing and exporting the levels of interest at a later stage. (Again, only the auto selected levels appeared).

The levels selector is also showing levels as having more rooms than they actually do. I have been going through and trying to get room assignments to work in revit, but when I delete rooms from the model, Pollination still seems to think they exist. This leads to the 3rd issue, where some of these non-existent rooms are trying to be processed and halt the progress of processing other rooms.

I’m using PlugIn version 2.107.0 and did a fresh install 2 days ago to solve a separate issue (Which was then fixed).

Any help or advice would be greatly appreciated.

(Image below is of the processing bar being stuck on this single room, I have left it for 10 mins plus, but no progress)

Hi, @alexsdiamond - and welcome to the forum. :wave:

I know that the level menu selection is tricky but I have always been able to get it right after a bit of clicking around. Can you record a quick screenshot of this problem so we can re-create it on our end.

This is not a bug. Pollination is working as expected. When you delete those rooms they still exist in the Revit document but they are categorized as not placed. You can right-click and delete them from the Revit document in step 4.

That said, and after reading your comment I wonder why don’t we just filter them beforehand so the user doesn’t have to deal with them. @ksobon, what do you think about filtering the rooms that are not placed out automatically?

I doubt that the non-placed rooms are the source of the issue. It is most likely something else in your model. In most cases, it is an aperture with a complicated frame that hasn’t been deselected in step 2.

Is it possible for you to share the model with us via private message? We can check the model and debug this issue for you.

I attempted to recreate what happens when trying to load rooms, but in trying no rooms now load. I will attempt again tomorrow morning to see if a PC reboot will yield anything.

I’ll have another go at this later, as well as trying to only assign rooms to the necessary parts of the model and see if that does anything.

I’ll have to check that is ok with my colleague but will send it over once I get approval.

@mostapha we used to filter out unplaced rooms from the UI in the past, but I remember that we had a request to put them back in there. Unless, the request here is to not show them in the count as that’s inflating the value at the level step, but then show them in the rooms step so that users can delete them?

Hey, @ksobon! I think we should just remove them altogether from our workflow, and not show them to the user. I don’t remember what was the request for putting them back in but I don’t see any benefits from having them there. Especially since the fix is to select and delete them! I would say filter them out through the whole process.

After a PC reboot and getting a fresh model, most of the issues seem to have stopped being an issue.
I did have another go at recreating some of the problems on the original model I was using, but it would keep getting blocked by a failure to process a certain room.

Thank you for the help with this, I’ll make sure to take small steps and record what I do in case anything happens again.

Great to hear that! There is a reason this exists! :sweat_smile:


It will be great if you can share this model or part of it with us to recreate this issue, and fix it for you!

Thank you! :raised_hands: