Local run failing using revit plugin

Hi all. I was trying to run an annual daylight simulation on local using the new revit pollination panel. But its failing within 5 seconds. The same run is successful running on cloud. I am sharing some screenshot.

This is the link to successful cloud based run Pollination Cloud App

Just an update. When I opened the same model in rhino pollination, and ran locally, it ran successfully. Only having issue with revit plugin running locally.

1 Like

Hi @asisnath, I imagine we are missing a few dependencies from the Revit plugin. I’ll check later today! Thank you for letting us know.

1 Like

Hi @asisnath - I had a quick look and the dependencies are actually there. Can you send me the full log file? It is in the same folder as the err.log file and is named logs.log. I believe one of the dependencies is missing but I’m not sure which one.


logs.log (30.7 KB)
Here it is @mostapha

Thank you, @asisnath! Here is the issue:

2023-04-27 01:01:31 INFO: ‘gendaymtx’ is not recognized as an internal or external command

I just checked, and we don’t ship Radiance with the Revit plugin. That’s the source of the issue.

@mingbo, can we add Radiance to the Revit installer? We are already including OpenStudio.

@asisnath, the temporary fix is to globally install Radiance on your system so it can find the Radiance commands from the global environment until we fix this issue.

Thanks for the update @mostapha. But i have radiance installed from rhino installer. Do I have to install again!

You do but it is not added to the PATH. You can add the radiance folder to the PATH and that should also solve the problem. To test if it has worked you should be able to open a new CMD and type rtrace -version and it should show you a version.

1 Like

Ok. But how to add to the path . Or else lets wait for the installer with radiance

Hi Antonello! The bug here is that the panel assigns the path to the Rhino’s ladybug-tools folder to the command for the local run. Mingbo has added Radiance to the installer and we should be using the new Radiance.

Hi, @asisnath!

We did some more debugging on our end and it should have actually worked on your end because you already have the Rhino plugin installed. Can you check the local simulation settings in the Revit Pollination panel?


Where doe the ladybug_tools path set to? Does that folder exist? And can you see Radiance under that folder?



@mostapha I did check the local simulation setting and it is set to Pollination_Revit folder by default. It didnt have Radiance folder.

Great! In that case, can you try the latest release of the Revit plugin? It is version 2.135.2. That should come with the Radiance installed.

1 Like

I am on it right away!

1 Like

@mostapha Finally it worked. I could successfully complete the daylight run Locally. Thank you for this great feature inside Revit!

Only one step I am not able to move to the result panel inside pollination panel.
I could see the finished analysis on panel.

But not able to load the next page , it is stuck in buffering mode. I tried to refresh but still buffering for the local run.

Excellent! That’s a good starting point.

Can you try to activate the debug mode, then right-click inside the panel and click on inspect, and finally go to the console tab and see what is being printed out when you try to go to the page? Here is how.

@antonellodinunzio - we should probably start adding a logger to the panel to make it easier to debug cases like this and the one that @aminigam92 is facing.

I did as you showed.

Thanks! I think the only remaining option is to do the famous “did you try to turn it on and off” trick and if that didn’t work we can set up a live session to debug it together next week.

1 Like

What I understand is shall I close Revit and reload everything?

I tried again after restarting cpu and still no luck. We can debug together as you said !