PO_SolveAdjacency command does not recognize "internal" surfaces

Hi all Pollination users,

I am experiencing some issues with PO_SolveAdjacency. I am aware that issues related to “solve adjacency” have been reported in the past and the functionality of the command has been improved after those reports, so I guess that this might be a model-related problem, although geometry does not seem to be the problem. The command does not recognize many of the internal surfaces, but instead it assumes that the boundary condition is “outdoors” (as seen below).

I tried to rebuild the rooms and reset the boundary conditions (PO_RebuildRooms, PO_ReserBoundaryConditions) but I got the same results. What’s interesting is that the command worked nicely when it was performed in a different, but similar, system (laptop) - I doubt though that this has something to do with laptop’s performance. So I tried to remove all components and reinstall the developer version, but the problem persists.

Any ideas of what might be the problem will be very much appreciated!

1 Like

Hello @etseno , welcome to the forum.

looks much like we both face the same issue. Wrote just a few minutes ago about the same problem here.

What comes to my mind when you talk about this, is the whole thing could be related to the latest update of Rhino also.
Because on my computer a familiar model was solved earlier also without problems, so I was quite surprised it didn’t work today. Since I haven’t upgraded Pollination ( it might be related to the latest update of Rhino to (7.11.21293.9001, 2021-10-20)
How about your versions?

Hi @martin6,

Thanks for the reply. I am using Rhino 7.11.21285.13001, 2021-10-12 and Pollination That’s actually interesting and I also believe that it might be a Rhino-version issue because when I ran the command before updating Rhino (although at the time I didn’t use the latest WIP developer plug in) it worked perfectly.

Hi @etseno and @martin6, I can do a test tomorrow unless @mingbo beats me to it.

Meanwhile it will always be helpful if you can share your model for testing, @etseno. Thanks!

Hi @etseno and @martin6,

Could you please share some sample models that we could use to constantly replicate this issue?

I am testing the plugin on my 3-year old laptop, but I don’t see any performance issue. But I am testing it on Rhino 6, I will take a look at the plugin on Rhino 7.

Hi @etseno, this issue has been resolved in version 0.125.1.