Pollination dominates the scene in Rendered View while Grashopper is open

Hi all together,

While I tried to show my friends the seasonal influence of the sun regarding their new house project, I found myself a bit distracted by explaining something about a new Plugin spoiling the fun with some strange behavior.
I didn’t define as single thing in Pollination regarding this file!
Any idea how I can get rid of such a display, without closing Grasshopper?

You can double click in the top GH window frame to reduce the window. Double click again to restore.

1 Like

@ayezioro, thank you for the tip.
It led me to a previously unknown way of how to work with the Grasshopper Window.

What I am trying to show is, if there is something active in Rhino out of the Grasshopper canvas, you can find it by highlighting parts of the canvas or like in this case the whole canvas.
The picture indicates an active Sunpath component, but the buildings are generated somewhere else, out of actually hidden data.

When I go to the Pollination Plugin and set, ColorByFaceType: False, nothing happens

Sure I could Bake the Sunpath and close Grasshopper and go on explaining things to my friends, but I’m pretty sure that’s not the way our developers here like things to work. :smiley:

@antonellodinunzio, can you help with this issue. It looks like that the issue comes from the Grasshopper side.

@martin6, what happens if you open a new file in Grasshopper. Doe the preview still exist? Or is it only show up with that specific Grasshopper file?

It’s the same with other files.

Here is the screen with EnergyPlus_Simulation.gh file

The moment I start to move the model with 3D mouse the screen turns black when I stop the movement. Maybe because I upgraded to Pollination.RH, Version=


Just realized the black screen in Rendered Mode stays after I close all gh files.
And also after closing Grasshopper.

I’m not able to work in redered mode anymore. Only while I move things are displayed.
When I open another file it’s the same.

Switching to Wireframe or other modes everything is fine with the Pollination display

The black screen appears only when I zoom in close. When I zoom out the display works

1 Like

Hi @martin6, Let me update to the latest version and see if I can recreate the errors on my side. Is there a step-by-step process that you can document for me to recreate this issue. I have not been able to recreate the issue on my side so far.

Actually I did nothing out of the ordinary.

Open a file without any Pollination work done ever.
Switch to Rendered Mode
Open a gh file.

That’s how it came up the first time.
But as you can see in the pictures, it’s the same with my Pollination file

For what is worth (about 2 cents) i think i’ve been there. I noticed that the preview component in GH shows in Rhino when the Preview is set to Off in Rendered mode. What i do is disable them completely for them to not be seen.
Give it a try. The workaround i use is using some of the Human plugin components instead of the GH Preview (like the PreviewMat).
Hope this helps,

1 Like

Thanks @ayezioro

Hi @martin6, I can’t replicate the black screen issue. I do not know how your gh files are made but this is the issue related to GH described by Abraham.



Thanks to both of you @antonellodinunzio & @ayezioro

Great work. That’s the origin of the displayed Geometrie.

Regarding the black screen I suspect in the meantime Rhino itself or something with my computer configuration as the origin of the totally or partly black screen.
Since it appears only in the Perspective Viewport. But no idea yet where to look?

I would check in the Tools>Options>Viewe>Display Modes> Rendered>Lighting scheme. Change to whatever you think and see if it solves the issue. I’m pretty sure it is around this area.


Yes @ayezioro you got it again

Switched back to No Lighting and the black is gone :smiley:

1 Like