Problem with Align rooms

Hi, I have a problem with aligning the extruded model and filling holes. However, I set the thresholds and set lines ( to set the outer boundary with the interior side of the external wall) and ref plane (for aligning rooms in corridors). I am sending some pictures of my setting and hope they can help to fix my problems.

Hi @eanvari - Thank you for the screenshots. The easiest way for us to debug this is if you can send us the files that are generated by the Revit plugin or send us the Revit model to try it on our end.

For the first one, open the log files and you should see the command that tries to align the geometry with the input and output files that are passed to the command.

Okay, here is the debug file. I’ll send the Revit model in a private message as well.
Debug.log (28.0 KB)

Hi @eanvari,

Thank you for sharing the log files. The alignment is failing because of the Revit plugin is passing the align distance as ft instead of mm. This is a bug on our end!

2023-09-09 19:32:46.6047|DEBUG|pollination_logger|& "C:\Program Files\pollination_revit\python\Scripts\dragonfly.exe" edit align --merge-colinear --output-file "C:\Users\Architect\AppData\Local\Temp\12cd8194-7029-46af-b920-d15ff9a1f10d\tmpF3B8.tmp" --distance 500ft "C:\Users\Architect\AppData\Local\Temp\12cd8194-7029-46af-b920-d15ff9a1f10d\tmpF3BA.tmp" "C:\Users\Architect\AppData\Local\Temp\12cd8194-7029-46af-b920-d15ff9a1f10d\tmpF3B9.tmp"|
2023-09-09 19:32:48.9505|DEBUG|pollination_logger|dragonfly.cli.edit - ERROR - Model align failed.
All Room2Ds of Story "LEVEL 1" are degenerate.

Can you try to change the align distance to 1.64 and try again? That’s about 500 mm.

cc: @ksobon

Thank you Mostapha, that was the problem.

@eanvari, I tested this with the latest version of the Revit plugin and I can’t recreate the error. Are you using an older version of the Revit plugin? If not, can you share the model with us privately to re-create the error on our end?

Yes, I use the 2.163.2 Version and still should add the ft value in align dist (mm) when my model has an IP unit system. Sure, I’ll send the model to you.

1 Like

I see! This is the key here. I don’t think we need the model. This should be good enough to recreate the error and resolve the issue. Thanks!

Okay, whenever you want, I can send the model as well.

@eanvari @mostapha this was a bug on my end. The UI would always show the “mm” value, but under the hood, it would actually use whatever settings you had set for that model, in this case, “ft” since it was an Imperial model. It should be fixed now.