Project Information - local .epw file

I have not been able to use the local file epw functionality in the “Project Information” interface.

Is this available yet or still in development? Obviously I can work-around so it is not a problem now, just wanted to raise the bug.

1 Like

Hey @byron ,

I can’t recreate your issue by using the URL to the same EPW file on OneBuilding:

Could this be related to the permissions on your OneDrive folder? Are you able to use the URL from OneBuilding without issues?

Hi @chriswmackey,

what you are showing - pasting a url - works fine for me too. What I am reporting is the local file functionality.

when you say url/file path, I assume you mean any local path should work. Although not sure if that would still need to be a .zip file to include ddy, or would it be direct .epw filepath.

Did I understand the intend wrongly?

I used another local file path (not on Onedrive) with same error.

ps. In Rhino 8, I get this error when hitting the EPW map button

Hey @byron ,

It looks like, the way @mingbo wrote it, it has to be a path to a .zip file like what you would download from EPWMap. I’m able to import it successfully if I just point to the .zip file that I downloaded:

Generally speaking, the URL is the more reliable way to set the EPW because you won’t end up with a broken link if you open your 3dm on another machine.

With that said, @mingbo , we should give a better error message if someone points the Weather Urls/Files to something that is not valid URL or zip file:

I can’t recreate your Rhino 8 issue, @byron . It’s possible that you have an old version of your Rhino 7 Pollination plugins loaded into your Rhino 8. This would also explain what is going on over here:

Did you use Rhino 8 WIP at any point? If so, can you go to the Rhino 8 PluginManager and try reloading the plugins. Admittedly, I can’t remember exactly how to reload them but I remember @mingbo and @mostapha showed me how to do it.

For sure there is some clash happening with my Rhino 7. What is odd is that it is happening on 2 or 3 different machines that I have tried. I would think that maybe the installer creates an issue but since you don’t get the errors, that is not an option.

If I look at my PluginManager, everything related to pollination, environmental analysis and Ladybug all points into “8.0” folders, under ProgramData, Appdata and Pollination folders on my machine.

Not sure where the mixe-up is happening. I was not able to do anything regarding the “reloading” that you mentioned.

Is there a chance that you used Rhino 8 WIP at any point on all of these machines?

If so, I know that’s the reason for your issues. I just can’t remember how I fixed it. I think some post on the McNeel forum helped me. I’ll see if I can look for it later over there.

100% had it on my work laptop, but I doubt I had it on my personal. But maybe I am wrong.
I tired searching the McNeel forum but to no avail, at least for the 20min search I did.

Will persist more later in the week when I get time.