Rhino 8 - AddtoDoc not working on Environmental Analysis Toolbar

When I generate sunpath, windrose or other graphs using the Environmental Analysis Toolbar in Rhino 8, they are generated fine, but the moment I AddToDoc, only the curves and text seem to be passed. All the meshes dissapear.

Maybe too early to try this on Rhino 8?

Hi @byron, that’s strange. @chriswmackey had developed the commands using Rhino 8. It might be because we haven’t released the latest version publicly yet. Can you remind me what version of the Rhino plugin are you currently using?

Thanks, @byron ,

I have been developing these commands in Rhino 8 so I’m doubtful that is the issue unless you have a really old service release of Rhino 8.

It seems your issue is specifically with the translation process to the Analysis mesh object that we created for the Rhino plugin, which allows you to customize the legend parameters of colored meshes that you have added to the Rhino scene.

Are you able to access this Analysis mesh for other studies? For example, can you use the “PO VisualizationSet” component to bake visualization sets of colored meshes from Grasshopper into Rhino?

Cc: @mingbo

Hi @chriswmackey,

thanks for your reply.
I am using Rhino Version 8 SR4 (8.4.24044.15001, 2024-02-13)

Doing a ‘PO VisualizationSet’ through GH works fine.

Tried again doing the Rhino toolbar version with same results (not showing meshes).

1 Like

Thanks, @byron .

I am using the exact same version of Rhino 8.4 as you have installed but I am unable to recreate the issue. Can you use the PO_CheckUpdates command to make sure that you have the most recent version of the Pollination Rhino plugin installed?

The most recent version should be 1.43.6.0:
image

If you can still recreate the issue with the latest version of the Pollination Rhino plugin, can you let me know what EPW file you are using to make the wind rose? I remember being able to create something like what you have here with an old version of the Rhino plugin where the values of the mesh didn’t match the number of faces. Maybe there’s something about this specific EPW that is causing one of these mesh-face matching issues.

@chriswmackey,

I do have the latest version indeed.

Give me a day to check my installations as there is something broken with my Rhino8. I seem to be missing the Rhino template files as well. I tried doing a full uninstall of all Rhinos from my machine, but probably need to go deeper.

Will give you an update soon

1 Like