Room/Space Properties Warning - Face has no surface type assigned


I’m not sure if this has been asked, but I couldn’t find info about it in the forum.

I’m trying to use the volume option for the geometry calculation to capture the sloped roof. The room heights seem to be all over the place in the visual and I’m also getting a warning. How do we solve this?




Hi @rwdhope, This is happening because the top face of the room volume is not touching a Revit element. For instance, they are left halfway through the room or they are crossing the roof because the roof element is not room bounding.


I cover this topic in this workshop. Starting around minute 52:00.

That being said, we are well aware that fixing all the room volumes can be a daunting task and we are working on a routine to support slanted roofs in extruded mode so you don’t have to do the clean-up as long as the walls are extruded.

Another option that I have been using/suggesting is to export the model as extruded to HBJSON, import it into Rhino, and then use the MoveEdge and other Rhino commands to adjust the geometry quickly. You can also extrude them all higher than where they should be, then draw a cutting plane/face and use the Trim command to delete the top part of the room. I recorded a video tutorial that shows the process.