Single-click installer for Rhino 6 - Missing LBT plugins in GH

Hi all,

Did anyone have issues with the single click installer [1.44] for Rhino 6?

The installation seems to suceed, the plugins don´t get loaded into gh.
I’ve tried with the GH only installer, and RHGH installer, both of which write two folders on:
C:\Program Files\ladybug_tools
C:\Program Files\pollination

Restarting the computer, and opening/closing Rhino 3 times doesn’t really get them to load.

I guess it could be some permission/computer issue, as the installer worked well for everyone else here in the office :sweat:


1 Like

Hi @rafaela, That is strange! I just tested a new installation and everything worked as expected. :point_down:

Do you see the message for setting the IronPython path?

The user objects should be under C:\Program Files\ladybug_tools\grasshopper\ladybug_grasshopper\user_objects. Can you see them there?

@mingbo, I forgot where we copy the loader file so Grasshopper loads all the user-objects? That might be the source of the issue.

I know! For some reason my installation is the only one that doesn’t work here in the office.

The IronPython message doesn’t show (1), while the User objects seem to be in the right place (2):

Thank you, @rafaela! It looks like the file that loads the userobjects is blocked on your machine.

@mingbo, can you remind me where should one look for the loader file(s)?

Hi @mostapha

The loaders for Rhino 6 are located in:

Hi @rafaela
The first thing to check if those Loader.gha and Loader.rhp files in both folders are not blocked.
The second item to check those files in both folders, and you can open them with Notepad. The path saved in the link file should point to the installation folders:
C:\Program Files\ladybug_tools\grasshopper and C:\Program Files\pollination\plugin\6.0

1 Like

Thanks @mingbo

a) None of the files is blocked, at least they dont show it when I look at the file properties (I’m not sure there is any other way they could be blocked)

b) regarding the loaders, I see there is a difference with the / in the file path. But even if I flip the / to , they dont load in Rhino/GH.

Hi @rafaela
That’s weird that your Rhino 6 doesn’t load those rhp and gha files. Would you be able to manually drag-drop those rhp files to Rhino 6 and gha files to Grasshopper, and re-open the Rhino 6 to see if it could be loaded automatically next time?


This worked! I dropped them and now they load every time I open Rhino/GH.
Thanks @mingbo

1 Like