Studies start running but CPU usage doesn't occur and therefore studies don't finish

Hello fellow Pollinators,

I am trying to run a very simple parametric study to test some new shading variables in my energy modelling script. The study only has 8 runs, and iterates between two options for number of shades (0 or 99), two options for the spacing between shades (0.3 or 0.6), and two options for the orientation of shades (horizontal or vertical).

Iterating the study using Colibri doesn’t seem to create any errors, and when I pollinate the study, the Pollinate component prepares the study without error, and the Check Study Status component says that the study is running. However, when I check the cloud study on the Pollination website, the CPU usage never changes from zero. Therefore, the study never actually runs, and never finishes.

I cancelled the first test study after 80 minutes of this situation, and tried it again, and currently I have two other test studies running to see if I can find the issue:

  1. Using a demo license on my personal account to run the study instead of the company account to see if the issue is with the company account/license.
  2. Using a rectangular plan to see if the issue is in the shape of the actual plan, which has a few non-orthogonal angles.

Unfortunately, all three test studies are still running without any CPU usage occuring.

This is what the setup for the parametric study looks like:

This is what it shows on the Pollination website:

After about 90mins of running time, this error showed up:

Please let me know if anyone might know what is causing this problem! Thanks in advance for any ideas!

Cheers, Anthony

Sorry, I couldn’t upload two of the screenshots as a new user.


Hi @anthonyschneider,

The simulations are running fine, but they are taking longer than usual because you have added the context shade to every single room in your model. See below.

That’s adding a substantial time to the shadow calculation step.

We only update the CPU usage at the end of every step of the simulation. These values will be updated once the first step of the simulation for running the energy simulation is finished.

@mingbo, this is similar to the error that we saw in the workshop. We should probably be more forgiving for this error from server and consider it as a warning that will be fixed in a few seconds.

Hello Mostapha,

Thank you for your reply!

Unfortunately, I don’t have the Rhino plug-in at the moment, and am wondering what is the correct way to add context shading?

My model uses a multiplied mid-floor approach, so based on the context, some floors may get more sunlight than others (upper levels should get more sun than mid floors and the ground floor). I assume that this means that each level and therefore each room needs to account for the context shading. Is this correct?

Currently I am adding the context shading in the Grasshopper script between adding boundary shades to the windows and applying HVAC settings to the rooms. This step comes after all three levels of my model have been merged into one list of rooms.

Should I instead add the context shading directly to the larger HB model in the “shades_” input to the “HB Model” component, just before it gets inputted to the Pollination recipe component? Unsure if this would actually streamline the calculation process?


Hi @anthonyschneider, can you share the Grasshopper script with us? It is probably a mistake in how you have set up the script.

Hi @anthonyschneider, here is the issue. You’re assigning the context shades to every room instead of assigning them to the model.

This is what the fixed version looks like.

Let me know if you have any other questions.

Hi Mostapha,

Was just in the middle of trying this myself! It worked!

The answer was indeed plugging the context shades straight into the “HB Model” component.

The test study with 8 runs ran in 15 mins with just under 2 hours of CPU usage.

Thank you so much for your help!

1 Like