Unable to download results

Hi,
I’ve sent a job that was successfully completed. It is a large outside radiation (on building envelope).
This is the job.
The issue is that i’m trying to see the results, but the Load Assets components fails and reports:

  1. Unable to download file

I assume the results are pretty big or too many files, but don’t know what to do with them now.
Any suggestions what I should/can do?

Thanks,
-A.

Hi @ayezioro, Thanks. I can recreate the error on my side. This is one for @mingbo to have a look first.

Hi @ayezioro, I have a follow up question. Is the main reason for downloading the results data visualization inside Rhino/Grasshopper? Or do you need to do some post-processing which is not currently part of the recipe?

Hi @mostapha,
For now is for visualizing results. So far i’m using the recipes as they are … hopefully … one day … i’ll change them or add.
-A.

1 Like

Hi @ayezioro, Just a quick update on the topic. @mingbo and @tyler have looked into this issue and the download error is happening because the zip file for the results is not generated on Pollination. We have some guesses for why this is the case but we will look into this closely this week and will give you a better update and hopefully also fix it for you.

2 Likes

Thanks for the update @mostapha!
-A.

Hi @ayezioro :wave:

Quick update on this issue you encountered: I have picked it up and am currently testing it in our staging environment. If all goes well the fix will be made public and you should be able to re-run the hobs where zipped data was missing.

I will try to zip all the missing files for your existing runs also but can’t promise I’ll manage to get it done :sweat_smile: Hope that’s an ok solution for you!

Cheers,

Antoine

Hi @antoinedao,
Thanks!
Don’t bother making a local solution for me. I can run the job again and have the results using the fixed solution.
Thanks again!!
-A.

Hi @ayezioro :wave: You should be able to run your large job and get the outputs zipped now. Let me know how it goes :grinning_face_with_smiling_eyes:

1 Like

Hi @antoinedao,
Thanks!
Unfortunately the error is still there.
I tried a new case/job. It took a couple of hours to finish (about 90K sensors). But when i connect the results to the Load Assets component it returns the 'nasty" error (1. Unable to download file).
I need to update something on my side?

-A.

1 Like

Thanks again for the feedback. I’m going to look into this further today and get back to you. Sorry about the delays this is causing :sweat:

No worries @antoinedao,
I noticed the slightly different error now and before.
The before was “Unable to download results”
and now “Unable to download file”.

Maybe this means something.
-A.

1 Like

@ayezioro you helped me uncover a bug in our workflow execution layer! Thank you! I have fixed it and tested it against the files you were using and am happy to say that i works!

Please give it one last try and rejoice with me when you eventually manage to download your results from our platform :raised_hands:

Glad to help @antoinedao!
I need to submit the job again or i can i download the existing results?
I’m asking because i’m still having the error.
Thanks,
-A.

Small update,
Now it seems to work. No error reported. But … Null results at the output items of the Load Assets component. Like so:


-A.

You will need to run it again unfortunately :sweat_smile:

Hi @ayezioro, can you share the link to the newly executed job? Thanks.

Hi @mostapha,
Just sent it. This is the link.
Thanks,
-A.

p.s. the job is finished. Still, as in the preview post, the outputs show Null values.
It can be caused because my internet connection at home. I’ll check again when i’ll be at the university.

Hi,
Another update.
After a while, the Load Assets component turned red and complained with this error (that we already know):

  1. Unable to download file

But … checking on my C:\Users\USERNAME\AppData\Local\Temp\Pollination\ folder, i see there this one (from today) jzxy2edt.p43.
Its size is huge 8.1Gb and has 32 *.ill files and sun-up-hours.txt and grids_info.json files.
So basically something good is happening but is not finished (or something else).
I’ll report back from the university when i get there, unless you have some words of wisdom in the meantime.

-A.

1 Like

I don’t have an insight to offer here but I can confirm that it also fails on my side.

If @antoinedao can confirm that the ZIP file is created then it is an issue on the Grasshopper plugin side.

cc: @mingbo