Annual Daylight Simulation

Hi all,

Running an annual daylight simulation for a sample room I get this error:

  1. Result folder contains no grids_info.json.
    From read_cda_from_folder(Handler-python)

And this is the grids_info.json

I tried generating the grid both in Rhino plugin and GH plugin but both with the same error.
I am wondering what causes this issue.

I would appreciate your help.

Hi @mahagh, A quick update for you. @mikkel and I looked into this issue and it only happens for local runs and for this specific recipe. We will document the issue for @mingbo to resolve this.

Meanwhile, you should be able to use an older version of the annual daylight recipe to run your studies. @mikkel, should be able to help you with the right version.

Hi @mahagh,

Until the issue is fixed for this recipe, here is what you can do in the meantime.

In case you do not know, we recently refactored the annual daylight recipes. You can see the announcement post here. This means that there actually is no older version of the recipe you are trying to run because the older version of annual-daylight is now continued as annual-daylight-enhanced.

So what you can do is to use annual-daylight-enhanced, or if you specifically want to use annual-daylight:0.10.10 you can use the LBT plugin. If you update your core libraries with the LB Version component, you should get a new version of the HB Annual Daylight component where you can switch between the annual daylight recipes with the enhanced_ input.

Btw, if you are going to simulate aperture groups, you have to you annual-daylight-enhanced.

Thanks @mostapha and @mikkel,

It worked well with annual-daylight-enhanced component.
To visualize my result, I just got an error for Heatmap component after updating LBT version.

  1. Solution exception:unexpected token ‘:’

Any idea how to solve this issue?


Hi @mahagh ,

That’s a bug we accidentally introduced into the development version of LBT 4 days ago. I assume you’re a user of the LB Versioner component since that’s the only way I know of that you could have gotten the bug on your end.

In any event, I just pushed a fix, which should be available with the Versioner in an hour. If you need the issue fixed right now, you can use the Versioner component to go back to version 1.6.71.

FYI, here’s the cross-referenced issued on the LBT forum:

Hi @mikkel,

Working with annual-daylight-enhanced component, I made the sensor grids in HB plugin Pollination and am wondering how to get meshes for result visualization.


Hi @mahagh,

You can use the HB Gert Grids and Views component to extract the meshes from the model.


If you use the -viz version of the recipe it already comes with a visualization-set that you can visualize in Rhino directly using the LB Preview VisualizationSet or PO VisualizationSet components.

Two more comments:

  1. We have fixed the bug that was causing the issue here, it should be available in the next public release in the next few days.
  2. I’m curious to know why you use the Grasshopper interface instead of the Rhino panel for scheduling the studies. For this particular case, the Rhino plugin would have likely been an easier option.

Thank you @mostapha,

I am not sure what is happening here:

  1. Solution exception:Expected number of data set values (1239) to align with the number of geometries (1), the number of geometry faces (2889), or the number of geometry vertices (11302).

Thanks for the update. look forward to using the updated one.

Thaks for bringing up. Mostly I use the GH interface for parametric analysis. But here, I tried to run it in Rhino but the model was not linked there, no option to select the WEA file and also no Run/Load result option down there.

And when I run PO_RunSimulation, this panel pops up.


Would be great to know what the issue is here.


For the first issue, try to flatten the values before connecting them to the input. I will write a longer answer to the rest of your questions when I get behind my computer.

@chriswmackey, should we update the error message for this component with a suggestion? Something like this:

Solution exception:Expected number of data set values (1239) to align with the number of geometries (1), the number of geometry faces (2889), or the number of geometry vertices (11302). Try to flatten the input values and join the input meshes into a single joined mesh.

1 Like

Thanks, @mostapha

Flattening did not help but grafting mesh input solved the issue.

Hey @mostapha ,

I would not want to change that message that is coming from the core libraries since “flattening” doesn’t really have broad use outside of Grasshopper. But I can add an extra error inside the component.

The message should probably include that @mahagh would need to BOTH flatten the data tree of _values and join the _mesh to get a single visualization set with one legend for everything.



Thank you! You need a white space between input and and.

I suspect you were using the older approach because we haven’t updated the user manual. Sorry about that! Try using the new Rhino panel instead.

I also updated the page on the user manual to the newer video.

Let us know if you have any other questions.

Thank you @mostapha. that was really helpful.