Fatal Error - Door cannot be added to AirBoundary Face "Face_6685887f"

I seem to have really messed something up. My file was working this morning and then I decided to split my basement room to have partial ground contact and then everything went haywire.

I now seem to be getting this AirBoundary issue for a new room, everytime I run the validate command.

Anyone have any ideas? I’ve fixed 3 rooms already and I have a feeling I’m doing something wrong.

Here’s an image of the error:


Hey @brentwatanabe, See here:

You can use this command to select all the AirBoundary faces and convert them to walls which should resolve the problem.

I suspect that you set the AirBoundary option to Yes when you were using the solve adjacency.

@mingbo, don’t we automatically change the type from AirBoundary to Wall when someone adds a subface to it? Was that for resetting the ground boundary condition?

Hi @mostapha ,

I think you’re right and I did set the air boundary to yes. I ended just redoing the Rhino cleanup from the original HBJSON file. I went a lot faster this time around. Luckily it’s not for a deadline :wink:

Based on the error I had tried to change the air boundary to a wall, but it didn’t resolve the issue. I’ll try again on the model I messed up and see if the combination of commands fixes it.

Thanks for finding that topic. Still learning what to search on the forum.


Feel free to share the model, and I can give it a try if you can’t figure it out on your end.