Problem with leed-daylight-option


I’m having issues running the LEED daylight option one recipe (Version 0.0.27), I keep getting the following error message from the “Check Study Status” component:
The error also appears in the console that pops up when running the recipe.

However when running the recipe from an older version (0.0.19) I receive another error message:

I am running it locally.

Any help would be greatly appreciated :slight_smile:

Kind regards,

Hi @albinber, Welcome to the forum.

What version of Pollination Grasshopper (not the recipe itself) are you using?

I’m using version 1.35.14

1 Like

Thanks! That is somewhat old at this point. Can you update to the latest version (1.43.11), and try again?

Updated to the latest version and got a new error instead, this one is coming from the Pollination component:

The log says everything was ran successfully but the output is empty

Hi @albinber,

Thank you for trying, and sorry for the issues. This is something that @mingbo should be able to comment on. This is not an issue with the recipe itself.

Can you share the logs folder from the local run with us? That will help to ensure that the recipe runs with no issues.

Hi @albinber,

Could you take a screenshot of your C:\Program Files\pollination\plugin\7.0\Pollination folder, and check if you could find those SQLite dlls in that folder?

Hi @mingbo ,
Those dlls do exist in my folder, the folder was called Pollination-GH if that makes any difference?

Below is the logs folder from the local run|attachment (27.1 KB)

Hi @albinber this seems weird. Are you using Rhino 7 or 8?
Could you please also provide the log files from the GH plugin? You can find the path from “About” dialog after you right click of any Pollination components. You can just zip the entire log folder.



I’m using Rhino 7. (2.8 KB)

Thanks, all logs seem to be from today, and I checked all of them, they don’t include the same “SQLite” error as yesterday. Would you be able to recreate the same “SQLite” error before sending me the logs?

I was able to recreate the error but it seems like no new logs are being created when running the recipe (V. 0.0.27) but they are generated when running version 0.0.19, but not with the SQL error

Logs will be kept in the same log file for each hour. So if you look for the latest one, it should have the new error.

I want to double check with you that from the previous logs, I found that you are running the simulation within C:\github\daylight\BoxModelMiddle folder, is it as expected? Does your current account have write access to that folder? It might cause the issue if you have limited access to the simulation folder. I’d suggest using the default one for a test.

1 Like

I should have write access to that folder, running with the default folder also returns the same SQLite error. I am not sure but I don’t think the log gets updated with the new errors when I run the recipe. But just in case here they are, I just did a run with the default folder with the same error. (5.4 KB)

Thank you for helping us debug this, @albinber! Do you face similar issues when you try to run other recipes such as the annual daylight recipe? Once we know if this is only happening for a certain version of the LEED recipe we can focus on the differences between the two.

I suspect the SQLite error happens when we try to update the local database for the local runs, and it should happen for other recipes as well but I can be wrong.

I also had a look through the logs, and from what I can see, I guess the error is happening because you run out of space on your hard drive when running the simulation. Can that be the case for the C drive where the TEMP folder is?

Thank you both for your help!
Running both the annual daylight and daylight factor recipes return the same error.
The C drive have ~80 gb left, that should be enough, no?

1 Like