Questions about Running LEED Daylight Option II

Hi @mikkel

I seem to get stuck when selecting a ‘study’. I am not sure why I need a study, but I tried creating one, and it is not obvious how to do so? Unable to select or create a study, which seems necessary in order to run the simulation:

You need to add the recipe to the project first. I suggest watching the video that @mikkel linked above.

1 Like

I was able to add a study by first creating a new ‘recipe’ in settings, and then adding the recipe to a study. But I got stuck on uploading the “.wea” file? I only have .epw, not sure where or how to find a .wea file for my location (Oslo)?

Thank you for helping me out @mostapha

If I understand correctly, Pollination is using the Autodesk-only format .wea, and not the Ladybug open-source file format .epw. This seems kinda strange, given that Pollination came from Ladybug?

I see that other recipes are using .epw, so might only be in this particular case (LEED OPT 2)? I would love to get some help in understanding how to generate a .wea file :blush:

That’s an input that should be more flexible. The reality is that a WEA file is two columns of data from an EPW file. Meanwhile, you should be able to download the WEA file for Oslo from here as part of the zipped package: \climatewebsite\WMO_Region_6_Europe\NOR_Norway

1 Like

I should also make a clarification here.

WEA is a format that was developed by Daysim. It’s different from the WEA that was the Ecotect weather file. As I mentioned a WEA file is a stripped-down version of an EPW file that only contains the irradiance values from the weather file which is all that we need for the daylight studies. In theory, you can use an EPW file. We should just make the input more flexible to work with either of the weather files.


Very awesome, thank you!

I’m having trouble getting a successful simulation on this recipe, is there some secret property to the hbjson that I need to add? I even tried with the most recent sample files from Github/ladybug-tools/3dmodels/sample-files/2021 but they failed as well… What am I missing here?

The Daylight ‘Option I’ seems to run fine…

Hi @jriise,

You can always debug the run by clicking on the debug button.

The UI is not great but here is the error message when it tries to create the sky.

And then checking the epw file, I can see why this is an error. For some reason, this WEA file is using hour 24 of the last day instead of hour 0 of the first day. This is invalid!


I created a valid wea file using the Radiance epw2wea command that should resolve this problem.

NOR_OS_Oslo.Blindern.014920_TMYx.2007-2021.wea (153.7 KB)


We should probably get in touch with Dru and his team and let them know about this issue in WEA files.

All these headaches should go away once we add handlers to the web interface so you can use an EPW file as an input.

1 Like

The quality of your response here is chefs-kiss Thank you for sharing!

1 Like

Is it possible to run this recipe with local hardware? I saw someone wanting to do this with Grasshopper (discussion link: Enable run local toggle on pollination ) however I would like to try this without involving Grasshopper. Possible?

Alternatively, is there some low-tier option for cloud simulation using the PollinationClient? I’ve set up an organisation, but seem to have 0 quota. Would like to do some testing before considering a purchase. Thank you!

Unfortunately, you can only run the recipes locally if you use one of the CAD plugins. You can also use the command line but that is more work than using the CAD plugins.

Send me an email or a private message on Discourse and we can discuss your case. We used to have a low tier which was meant to be used for cases like this but it fired back and we removed it.

1 Like

Thanks @mostapha, I shot you an email.