Running Daylight Recipes with Run Locally Option

Hi all,

Have you ever tried running public recipes with the “run locally” option (Rhino WIP)? I’m having difficulty running the annual daylight recipe from my local system. The simulation ends in less than 10 seconds with the errors shown below.

To my understanding, a similar error was reported before for large models and all of the latest Radiance recipes on Pollination had been updated for the workflow. So, I might be missing something else.

Here is the configuration for the simulation.

PS: I was able to run the same model on cloud platform and loaded the results in Rhino successfully.


Hi, @hlkocalioglu - thank you for sharing the logs. Here is the error:

2022-11-15 15:47:54 INFO: Usage: honeybee-radiance multi-phase prepare-multiphase [OPTIONS] FOLDER
2022-11-15 15:47:54 INFO: GRID_COUNT
2022-11-15 15:47:54 INFO: Try 'honeybee-radiance multi-phase prepare-multiphase --help' for help.
2022-11-15 15:47:54 INFO: 
2022-11-15 15:47:54 INFO: Error: no such option: --all-states

This is most likely because the version of honeybee-radiance that is installed with the version of Rhino plugin that you are using is older than the version of honeybee-radiance that is used by the recipe. The easiest way to fix this issue is to install the latest version of the Rhino plugin. I just tested it locally and it worked as expected.

@chriswmackey - this is one of those cases that is not easy to catch for us, and the reason that I think we should use containers for running the recipes locally.

@mingbo, there is a bug for loading the results locally after the simulation is finished. It is not looking into the right directory. I will document it for you separately.

Thanks for explanation @mostapha - It is working now. So, I will keep watching for a possible solution on loading the results error.